aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndreas Steffen <andreas.steffen@strongswan.org>2014-05-02 20:10:53 +0200
committerAndreas Steffen <andreas.steffen@strongswan.org>2014-05-03 15:28:17 +0200
commit9be1c8d1759dbedc2b9986f9f43a56b754cf56a6 (patch)
tree107fc29d72c66791bd1341e4dd82564c6b5b1dce /src/Makefile.am
parenta81bd670b086bd4b848dc1ff71e79e79c8f61da1 (diff)
downloadstrongswan-9be1c8d1759dbedc2b9986f9f43a56b754cf56a6.tar.bz2
strongswan-9be1c8d1759dbedc2b9986f9f43a56b754cf56a6.tar.xz
aikgen generates AIK private/public key pairs
aikgen outputs a binary AIK private key blob and the AIK public key. Optionally the Identity Request encrypted with the public key of the Privacy CA can be output.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 93da4893f..e76eb4398 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -119,3 +119,7 @@ endif
if USE_INTEGRITY_TEST
SUBDIRS += checksum
endif
+
+if USE_AIKGEN
+ SUBDIRS += aikgen
+endif