aboutsummaryrefslogtreecommitdiffstats
path: root/src/charon-tkm/Makefile.am
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2013-11-05 18:29:40 +0100
committerTobias Brunner <tobias@strongswan.org>2013-11-27 18:35:44 +0100
commitd6032bff8b8461aa7714fed61ba82bf63ca0b605 (patch)
tree5bde82f94ca89d730341023776655e791c2ff2a4 /src/charon-tkm/Makefile.am
parent70f44613597a32a16e79806670c254d2d5984e0b (diff)
downloadstrongswan-d6032bff8b8461aa7714fed61ba82bf63ca0b605.tar.bz2
strongswan-d6032bff8b8461aa7714fed61ba82bf63ca0b605.tar.xz
charon-tkm: Migrate tests to our own test runner
Due to problems with the external libraries tkm_init/deinit can't be called for each test case. Because of this leak detective has to be disabled for these tests.
Diffstat (limited to 'src/charon-tkm/Makefile.am')
-rw-r--r--src/charon-tkm/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/charon-tkm/Makefile.am b/src/charon-tkm/Makefile.am
index c3da7d7f4..c06864a57 100644
--- a/src/charon-tkm/Makefile.am
+++ b/src/charon-tkm/Makefile.am
@@ -21,6 +21,10 @@ BUILD_OPTS = \
-cargs $(AM_CPPFLAGS) $(DEFS) \
-largs $(LIBLD) $(LIBFL)
+TEST_OPTS = \
+ -cargs -DBUILDDIR=\"${abs_top_builddir}\" \
+ -largs -L$(OBJ)/libstrongswan/tests/.libs -ltest
+
# plugins to enable
PLUGINS = \
kernel-netlink \
@@ -35,11 +39,11 @@ build_charon: build_charon.gpr src/charon-tkm.c
@$(GPRBUILD) -p $< $(BUILD_OPTS)
build_tests: build_tests.gpr
- @$(GPRBUILD) -p $< $(BUILD_OPTS) -cargs @CHECK_CFLAGS@ -largs @CHECK_LIBS@
+ @$(GPRBUILD) -p $< $(BUILD_OPTS) $(TEST_OPTS)
if UNITTESTS
check: build_tests
- @LD_LIBRARY_PATH=$(LIBPT) obj/test_runner
+ @LD_LIBRARY_PATH=$(LIBPT) obj/tests
else
check:
@echo "reconfigure with --enable-unit-tests"