aboutsummaryrefslogtreecommitdiffstats
path: root/src/charon/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2007-03-13 15:01:02 +0000
committerMartin Willi <martin@strongswan.org>2007-03-13 15:01:02 +0000
commitb0f24449ddaff4a66b7b88ceef796f511cb6cb6d (patch)
treebfe36c7acf4873c1daec42b11e8d0247f1c07dbf /src/charon/Makefile.am
parentd2940fd78cd62f3499415fc9b3235430d99e92f0 (diff)
downloadstrongswan-b0f24449ddaff4a66b7b88ceef796f511cb6cb6d.tar.bz2
strongswan-b0f24449ddaff4a66b7b88ceef796f511cb6cb6d.tar.xz
added EAP-SIM authentication
client side only uses an external SIM reader library specified with SIM_READER_LIB untested
Diffstat (limited to 'src/charon/Makefile.am')
-rw-r--r--src/charon/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/charon/Makefile.am b/src/charon/Makefile.am
index 0eb3b4981..c422939f0 100644
--- a/src/charon/Makefile.am
+++ b/src/charon/Makefile.am
@@ -1,8 +1,17 @@
# SUBDIRS = . testing
-eap_LTLIBRARIES =
+eap_LTLIBRARIES = libeapidentity.la
+
+# always build EAP Identity module
+libeapidentity_la_SOURCES = sa/authenticators/eap/eap_identity.h sa/authenticators/eap/eap_identity.c
+libeapidentity_la_LDFLAGS = -module
# build optional EAP modules
+if BUILD_EAP_SIM
+ eap_LTLIBRARIES += libeapsim.la
+ libeapsim_la_SOURCES = sa/authenticators/eap/eap_sim.h sa/authenticators/eap/eap_sim.c
+ libeapsim_la_LDFLAGS = -module
+endif
ipsec_PROGRAMS = charon