aboutsummaryrefslogtreecommitdiffstats
path: root/src/charon/plugins/resolve/Makefile.am
diff options
context:
space:
mode:
authorAndreas Steffen <andreas.steffen@strongswan.org>2009-09-20 19:06:58 +0200
committerAndreas Steffen <andreas.steffen@strongswan.org>2009-09-20 19:06:58 +0200
commit4819ec6a71cccc7ba9d433969ae1d8a661073078 (patch)
treeaff50a69756abfe564ba68ea527c3a2a310cae00 /src/charon/plugins/resolve/Makefile.am
parent03f096df7e955c6ab065a05ad806f2172d56a021 (diff)
downloadstrongswan-4819ec6a71cccc7ba9d433969ae1d8a661073078.tar.bz2
strongswan-4819ec6a71cccc7ba9d433969ae1d8a661073078.tar.xz
resolv_conf plugin renamed to resolve
Diffstat (limited to 'src/charon/plugins/resolve/Makefile.am')
-rw-r--r--src/charon/plugins/resolve/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/charon/plugins/resolve/Makefile.am b/src/charon/plugins/resolve/Makefile.am
new file mode 100644
index 000000000..9d18b00b4
--- /dev/null
+++ b/src/charon/plugins/resolve/Makefile.am
@@ -0,0 +1,13 @@
+
+INCLUDES = -I$(top_srcdir)/src/libstrongswan -I$(top_srcdir)/src/charon
+
+AM_CFLAGS = -rdynamic \
+ -DRESOLV_CONF=\"${resolv_conf}\"
+
+plugin_LTLIBRARIES = libstrongswan-resolve.la
+libstrongswan_resolve_la_SOURCES = \
+ resolve_plugin.h resolve_plugin.c \
+ resolve_handler.h resolve_handler.c
+libstrongswan_resolve_la_LDFLAGS = -module -avoid-version
+
+