aboutsummaryrefslogtreecommitdiffstats
path: root/src/include/Makefile.am
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2015-09-07 12:04:55 +0200
committerTobias Brunner <tobias@strongswan.org>2015-09-07 14:07:46 +0200
commite7143fe998f768732f65f3ce5225ace4a96ddd13 (patch)
tree18b45b266060b4456e230f14d88b186ae9fd4a2c /src/include/Makefile.am
parenta215008c11e6f598438a19a4a4b88e63fd4275f4 (diff)
downloadstrongswan-e7143fe998f768732f65f3ce5225ace4a96ddd13.tar.bz2
strongswan-e7143fe998f768732f65f3ce5225ace4a96ddd13.tar.xz
include: Add linux/socket.h
__kernel_sa_family_t is defined and used since Linux 3.1, so on systems with older kernels (like CentOS 6.7, which still ships a 2.6.32 kernel) the build with the current UAPI headers fails. And using the native headers on such system does not really work either because we use structs, defines, and enum values from the newer headers in the kernel-netlink plugin. __kernel_sa_family_t is defined in linux/socket.h so we ship that too (in particular the simplified UAPI version from Linux 3.7+). Fixes #1099.
Diffstat (limited to 'src/include/Makefile.am')
-rw-r--r--src/include/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/include/Makefile.am b/src/include/Makefile.am
index 0284c094a..8e6db88a4 100644
--- a/src/include/Makefile.am
+++ b/src/include/Makefile.am
@@ -1,2 +1,2 @@
EXTRA_DIST = linux/if_alg.h linux/ipsec.h linux/netlink.h linux/rtnetlink.h \
- linux/pfkeyv2.h linux/udp.h linux/xfrm.h sys/queue.h
+ linux/pfkeyv2.h linux/udp.h linux/socket.h linux/xfrm.h sys/queue.h