aboutsummaryrefslogtreecommitdiffstats
path: root/src/libcharon/plugins/eap_dynamic/Makefile.am
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2012-08-31 12:23:38 +0200
committerTobias Brunner <tobias@strongswan.org>2012-08-31 12:25:41 +0200
commit868409139b00f24607baab2d81b873cb1a5a9e5b (patch)
treec231793562bcfefb5280fba99ba59328a0386545 /src/libcharon/plugins/eap_dynamic/Makefile.am
parent7b1c711ea00b6199045a9537f667e79db0032ae7 (diff)
parentcbe244a5fe81268a1aba30f871d57d81ee6e5e6e (diff)
downloadstrongswan-868409139b00f24607baab2d81b873cb1a5a9e5b.tar.bz2
strongswan-868409139b00f24607baab2d81b873cb1a5a9e5b.tar.xz
Merge branch 'eap-client-select'
This brings support for EAP-Nak payloads on the client (to select a specific or supported method), and the server (via the eap-dynamic plugin which selects a method supported/requested by the client).
Diffstat (limited to 'src/libcharon/plugins/eap_dynamic/Makefile.am')
-rw-r--r--src/libcharon/plugins/eap_dynamic/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/libcharon/plugins/eap_dynamic/Makefile.am b/src/libcharon/plugins/eap_dynamic/Makefile.am
new file mode 100644
index 000000000..0d07fbf35
--- /dev/null
+++ b/src/libcharon/plugins/eap_dynamic/Makefile.am
@@ -0,0 +1,16 @@
+
+INCLUDES = -I$(top_srcdir)/src/libstrongswan -I$(top_srcdir)/src/libhydra \
+ -I$(top_srcdir)/src/libcharon
+
+AM_CFLAGS = -rdynamic
+
+if MONOLITHIC
+noinst_LTLIBRARIES = libstrongswan-eap-dynamic.la
+else
+plugin_LTLIBRARIES = libstrongswan-eap-dynamic.la
+endif
+
+libstrongswan_eap_dynamic_la_SOURCES = \
+ eap_dynamic_plugin.h eap_dynamic_plugin.c eap_dynamic.h eap_dynamic.c
+
+libstrongswan_eap_dynamic_la_LDFLAGS = -module -avoid-version