aboutsummaryrefslogtreecommitdiffstats
path: root/src/libhydra/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2013-07-17 14:45:39 +0200
committerMartin Willi <martin@revosec.ch>2013-07-18 14:59:19 +0200
commit19cb07b89050c0e3ea6a11e1914318c4ff1284b5 (patch)
tree46313e34da73df7e8474c24122d97261f98b1d06 /src/libhydra/Makefile.am
parentc577b5eb44bb6f515ebbb532b8c2f802968d7771 (diff)
downloadstrongswan-19cb07b89050c0e3ea6a11e1914318c4ff1284b5.tar.bz2
strongswan-19cb07b89050c0e3ea6a11e1914318c4ff1284b5.tar.xz
automake: replace INCLUDES by AM_CPPFLAGS
INCLUDES are now deprecated and throw warnings when using automake 1.13. We now also differentiate AM_CPPFLAGS and AM_CFLAGS, where includes and defines are passed to AM_CPPFLAGS only.
Diffstat (limited to 'src/libhydra/Makefile.am')
-rw-r--r--src/libhydra/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/src/libhydra/Makefile.am b/src/libhydra/Makefile.am
index 1c7b3ba43..a2a164bd9 100644
--- a/src/libhydra/Makefile.am
+++ b/src/libhydra/Makefile.am
@@ -13,11 +13,11 @@ kernel/kernel_listener.h
libhydra_la_LIBADD =
-INCLUDES = -I$(top_srcdir)/src/libstrongswan
-AM_CFLAGS = \
--DIPSEC_DIR=\"${ipsecdir}\" \
--DPLUGINDIR=\"${plugindir}\" \
--DSTRONGSWAN_CONF=\"${strongswan_conf}\"
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan \
+ -DIPSEC_DIR=\"${ipsecdir}\" \
+ -DPLUGINDIR=\"${plugindir}\" \
+ -DSTRONGSWAN_CONF=\"${strongswan_conf}\"
EXTRA_DIST = Android.mk
@@ -78,4 +78,3 @@ if MONOLITHIC
libhydra_la_LIBADD += plugins/resolve/libstrongswan-resolve.la
endif
endif
-