aboutsummaryrefslogtreecommitdiffstats
path: root/src/libipsec/Makefile.am
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2012-07-13 13:32:27 +0200
committerTobias Brunner <tobias@strongswan.org>2012-08-08 15:41:03 +0200
commitb50f56f326d1e58d13f4287280799236fd239a05 (patch)
treecbee4e217429da513516c2073305483da12e29f0 /src/libipsec/Makefile.am
parent914479370ed23aa420a15ef3f19c2c39dce3b133 (diff)
downloadstrongswan-b50f56f326d1e58d13f4287280799236fd239a05.tar.bz2
strongswan-b50f56f326d1e58d13f4287280799236fd239a05.tar.xz
Added class to relay IPsec events (like expiration) to listeners
Currently, only expiration of IPsec SAs is supported. Later other events for e.g. acquires or changed NAT endpoints could be added.
Diffstat (limited to 'src/libipsec/Makefile.am')
-rw-r--r--src/libipsec/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/libipsec/Makefile.am b/src/libipsec/Makefile.am
index 3de8f82bc..c1024930d 100644
--- a/src/libipsec/Makefile.am
+++ b/src/libipsec/Makefile.am
@@ -4,6 +4,8 @@ libipsec_la_SOURCES = \
ipsec.c ipsec.h \
esp_context.c esp_context.h \
esp_packet.c esp_packet.h \
+ipsec_event_listener.h \
+ipsec_event_relay.c ipsec_event_relay.h \
ipsec_sa.c ipsec_sa.h \
ipsec_sa_mgr.c ipsec_sa_mgr.h