aboutsummaryrefslogtreecommitdiffstats
path: root/src/libpts/Makefile.am
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2013-09-04 14:25:22 +0200
committerAndreas Steffen <andreas.steffen@strongswan.org>2013-09-12 01:44:49 +0200
commit9af44ef5d9534cf6a12c0ddd90f9cad5648dcd28 (patch)
tree5a071b7524ed142b46210c2009b4c65b72465ce7 /src/libpts/Makefile.am
parent3cb4552da62fc5c1550aa5b46a9a52ae2a1737c6 (diff)
downloadstrongswan-9af44ef5d9534cf6a12c0ddd90f9cad5648dcd28.tar.bz2
strongswan-9af44ef5d9534cf6a12c0ddd90f9cad5648dcd28.tar.xz
Build all shared libraries with -no-undefined and link them properly
The flag is required to convince libtool on Cygwin to build DLLs. But on Windows these shared libraries can not have undefined symbols, so we have to link them explicitly to the libraries they reference. For plugins this is currently not done, so only the monolithic build is supported. The plugin loader wouldn't be able to load DLLs anyway, as it tries to load files that don't exist on Cygwin.
Diffstat (limited to 'src/libpts/Makefile.am')
-rw-r--r--src/libpts/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/libpts/Makefile.am b/src/libpts/Makefile.am
index 2c02fd18a..48bb46c7a 100644
--- a/src/libpts/Makefile.am
+++ b/src/libpts/Makefile.am
@@ -3,9 +3,15 @@ AM_CPPFLAGS = \
-I$(top_srcdir)/src/libtncif \
-I$(top_srcdir)/src/libimcv
+AM_LDFLAGS = \
+ -no-undefined
+
ipseclib_LTLIBRARIES = libpts.la
-libpts_la_LIBADD = $(top_builddir)/src/libimcv/libimcv.la
+libpts_la_LIBADD = \
+ $(top_builddir)/src/libstrongswan/libstrongswan.la \
+ $(top_builddir)/src/libtncif/libtncif.la \
+ $(top_builddir)/src/libimcv/libimcv.la
if USE_TROUSERS
libpts_la_LIBADD += -ltspi