aboutsummaryrefslogtreecommitdiffstats
path: root/src/libstrongswan/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2015-04-02 14:02:57 +0200
committerMartin Willi <martin@revosec.ch>2015-04-13 15:31:58 +0200
commitf155880eda515b8424e4984cb39cdf38946356f2 (patch)
tree870a1ab988a176141ab38383c24c906b81cceec7 /src/libstrongswan/Makefile.am
parent6a84a4049d6f7625dd585e39b7b6f871ec8e5bf6 (diff)
downloadstrongswan-f155880eda515b8424e4984cb39cdf38946356f2.tar.bz2
strongswan-f155880eda515b8424e4984cb39cdf38946356f2.tar.xz
cpu-feature: Add a common class to query available CPU features
Currently supported is x86/x64 via cpuid() for some common features.
Diffstat (limited to 'src/libstrongswan/Makefile.am')
-rw-r--r--src/libstrongswan/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/libstrongswan/Makefile.am b/src/libstrongswan/Makefile.am
index 2521b3e77..f7380728a 100644
--- a/src/libstrongswan/Makefile.am
+++ b/src/libstrongswan/Makefile.am
@@ -34,7 +34,7 @@ pen/pen.c plugins/plugin_loader.c plugins/plugin_feature.c processing/jobs/job.c
processing/jobs/callback_job.c processing/processor.c processing/scheduler.c \
processing/watcher.c resolver/resolver_manager.c resolver/rr_set.c \
selectors/traffic_selector.c settings/settings.c settings/settings_types.c \
-settings/settings_parser.y settings/settings_lexer.l \
+settings/settings_parser.y settings/settings_lexer.l utils/cpu_feature.c \
utils/utils.c utils/chunk.c utils/debug.c utils/enum.c utils/identification.c \
utils/lexparser.c utils/optionsfrom.c utils/capabilities.c utils/backtrace.c \
utils/parser_helper.c utils/test.c utils/process.c utils/utils/strerror.c
@@ -103,7 +103,7 @@ threading/mutex.h threading/condvar.h threading/spinlock.h threading/semaphore.h
threading/rwlock.h threading/rwlock_condvar.h threading/lock_profiler.h \
utils/utils.h utils/chunk.h utils/debug.h utils/enum.h utils/identification.h \
utils/lexparser.h utils/optionsfrom.h utils/capabilities.h utils/backtrace.h \
-utils/leak_detective.h utils/printf_hook/printf_hook.h \
+utils/cpu_feature.h utils/leak_detective.h utils/printf_hook/printf_hook.h \
utils/printf_hook/printf_hook_vstr.h utils/printf_hook/printf_hook_builtin.h \
utils/parser_helper.h utils/test.h utils/integrity_checker.h utils/process.h \
utils/utils/strerror.h utils/compat/windows.h utils/compat/apple.h