aboutsummaryrefslogtreecommitdiffstats
path: root/src/libstrongswan/plugins/ctr/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2010-08-13 19:39:59 +0200
committerMartin Willi <martin@revosec.ch>2010-08-13 19:39:59 +0200
commit272f0e1ae4b802846c25c381895dba7f9536fb6b (patch)
treec9667ea464dd672012fd25e1b620c8d1db3d986f /src/libstrongswan/plugins/ctr/Makefile.am
parentc03b0d7e6bd2e23fe2f219103ce52cdff629bea7 (diff)
downloadstrongswan-272f0e1ae4b802846c25c381895dba7f9536fb6b.tar.bz2
strongswan-272f0e1ae4b802846c25c381895dba7f9536fb6b.tar.xz
Added a counter mode wrapper plugin operating on existing CBC crypters
Diffstat (limited to 'src/libstrongswan/plugins/ctr/Makefile.am')
-rw-r--r--src/libstrongswan/plugins/ctr/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/libstrongswan/plugins/ctr/Makefile.am b/src/libstrongswan/plugins/ctr/Makefile.am
new file mode 100644
index 000000000..893171aab
--- /dev/null
+++ b/src/libstrongswan/plugins/ctr/Makefile.am
@@ -0,0 +1,16 @@
+
+INCLUDES = -I$(top_srcdir)/src/libstrongswan
+
+AM_CFLAGS = -rdynamic
+
+if MONOLITHIC
+noinst_LTLIBRARIES = libstrongswan-ctr.la
+else
+plugin_LTLIBRARIES = libstrongswan-ctr.la
+endif
+
+libstrongswan_ctr_la_SOURCES = \
+ ctr_plugin.h ctr_plugin.c \
+ ctr_ipsec_crypter.h ctr_ipsec_crypter.c
+
+libstrongswan_ctr_la_LDFLAGS = -module -avoid-version