aboutsummaryrefslogtreecommitdiffstats
path: root/src/libstrongswan/plugins/openssl/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2013-07-17 14:45:39 +0200
committerMartin Willi <martin@revosec.ch>2013-07-18 14:59:19 +0200
commit19cb07b89050c0e3ea6a11e1914318c4ff1284b5 (patch)
tree46313e34da73df7e8474c24122d97261f98b1d06 /src/libstrongswan/plugins/openssl/Makefile.am
parentc577b5eb44bb6f515ebbb532b8c2f802968d7771 (diff)
downloadstrongswan-19cb07b89050c0e3ea6a11e1914318c4ff1284b5.tar.bz2
strongswan-19cb07b89050c0e3ea6a11e1914318c4ff1284b5.tar.xz
automake: replace INCLUDES by AM_CPPFLAGS
INCLUDES are now deprecated and throw warnings when using automake 1.13. We now also differentiate AM_CPPFLAGS and AM_CFLAGS, where includes and defines are passed to AM_CPPFLAGS only.
Diffstat (limited to 'src/libstrongswan/plugins/openssl/Makefile.am')
-rw-r--r--src/libstrongswan/plugins/openssl/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/libstrongswan/plugins/openssl/Makefile.am b/src/libstrongswan/plugins/openssl/Makefile.am
index 7ae5ea43e..cbfd69b71 100644
--- a/src/libstrongswan/plugins/openssl/Makefile.am
+++ b/src/libstrongswan/plugins/openssl/Makefile.am
@@ -1,7 +1,9 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan \
+ -DFIPS_MODE=${fips_mode}
-INCLUDES = -I$(top_srcdir)/src/libstrongswan
-
-AM_CFLAGS = -rdynamic -DFIPS_MODE=${fips_mode}
+AM_CFLAGS = \
+ -rdynamic
if MONOLITHIC
noinst_LTLIBRARIES = libstrongswan-openssl.la
@@ -31,4 +33,3 @@ libstrongswan_openssl_la_SOURCES = \
libstrongswan_openssl_la_LDFLAGS = -module -avoid-version
libstrongswan_openssl_la_LIBADD = -lcrypto
-