aboutsummaryrefslogtreecommitdiffstats
path: root/src/scepclient/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2006-05-18 06:22:37 +0000
committerMartin Willi <martin@strongswan.org>2006-05-18 06:22:37 +0000
commit7626bef673a10b774db65c76e09d6c1f7056be83 (patch)
tree13c3fafcc3b518e80157061f10d642a213da8478 /src/scepclient/Makefile.am
parent32d24cb5132efd8b9b4109a10a74fb01193bd765 (diff)
downloadstrongswan-7626bef673a10b774db65c76e09d6c1f7056be83.tar.bz2
strongswan-7626bef673a10b774db65c76e09d6c1f7056be83.tar.xz
- fixed compliation error using --enable-smartcard
Diffstat (limited to 'src/scepclient/Makefile.am')
-rw-r--r--src/scepclient/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/scepclient/Makefile.am b/src/scepclient/Makefile.am
index 0031b0348..079e25a35 100644
--- a/src/scepclient/Makefile.am
+++ b/src/scepclient/Makefile.am
@@ -9,6 +9,11 @@ scepclient_LDADD = asn1.o ca.o crl.o certs.o constants.o defs.o fetch.o id.o \
$(top_srcdir)/src/libfreeswan/libfreeswan.a $(top_srcdir)/src/libcrypto/libcrypto.a \
-lgmp
+# This compile option activates smartcard support
+if USE_SMARTCARD
+ scepclient_LDADD += -ldl
+endif
+
dist_man_MANS = scepclient.8
PLUTODIR=$(top_srcdir)/src/pluto