aboutsummaryrefslogtreecommitdiffstats
path: root/src/starter/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2006-05-16 14:24:03 +0000
committerMartin Willi <martin@strongswan.org>2006-05-16 14:24:03 +0000
commitf2c2d395ff756505be10b9d3e8420af498f33cc2 (patch)
tree7202a334e20710bab1d0b3e848ecc964168ccf5f /src/starter/Makefile.am
parenteedfdfbe6e15ecc724eca705688472e8be73afec (diff)
downloadstrongswan-f2c2d395ff756505be10b9d3e8420af498f33cc2.tar.bz2
strongswan-f2c2d395ff756505be10b9d3e8420af498f33cc2.tar.xz
- introduced autotools
- first working version - make dist should work - things to do: - UML testing! - more cleanups
Diffstat (limited to 'src/starter/Makefile.am')
-rw-r--r--src/starter/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/starter/Makefile.am b/src/starter/Makefile.am
new file mode 100644
index 000000000..1c050e40e
--- /dev/null
+++ b/src/starter/Makefile.am
@@ -0,0 +1,32 @@
+ipsec_PROGRAMS = starter
+starter_SOURCES = y.tab.c netkey.c y.tab.h parser.h args.h netkey.h \
+starterwhack.c starterwhack.h starterstroke.c invokepluto.c confread.c \
+starterstroke.h interfaces.c invokepluto.h confread.h interfaces.h args.c \
+keywords.c files.h keywords.h cmp.c starter.c cmp.h exec.c invokecharon.c \
+exec.h invokecharon.h lex.yy.c
+
+INCLUDES = -I$(top_srcdir)/src/libfreeswan -I$(top_srcdir)/src/pluto -I$(top_srcdir)/src/whack -I$(top_srcdir)/src/stroke
+AM_CFLAGS = -DIPSEC_DIR=\"${ipsecdir}\" -DIPSEC_CONFDIR=\"${confdir}\" -DIPSEC_PIDDIR=\"${piddir}\" -DDEBUG
+starter_LDADD = loglite.o defs.o $(top_srcdir)/src/libfreeswan/libfreeswan.a
+EXTRA_DIST = parser.l parser.y keywords.txt
+
+PLUTODIR=$(top_srcdir)/src/pluto
+OPENACDIR=$(top_srcdir)/src/openac
+
+# TODO: get gperf from ./configure
+GPERF=gperf
+
+lex.yy.c: y.tab.c parser.l parser.y parser.h
+ $(LEX) parser.l
+
+y.tab.c: parser.l parser.y parser.h
+ $(YACC) -v -d parser.y
+
+keywords.c: keywords.txt keywords.h
+ $(GPERF) -C -G -t < keywords.txt > keywords.c
+
+loglite.o: $(OPENACDIR)/loglite.c $(PLUTODIR)/log.h
+ $(CC) $(AM_CFLAGS) $(INCLUDES) -c -o $@ $<
+
+defs.o: $(PLUTODIR)/defs.c $(PLUTODIR)/defs.h
+ $(CC) $(AM_CFLAGS) $(INCLUDES) -c -o $@ $<