aboutsummaryrefslogtreecommitdiffstats
path: root/src/starter/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2006-05-19 08:59:19 +0000
committerMartin Willi <martin@strongswan.org>2006-05-19 08:59:19 +0000
commitfea5e716c47444c760b6103ef23f77c2120d891c (patch)
tree2291e91445a8652ad636293e4e58af055b1c25e3 /src/starter/Makefile.am
parent2403d26472b30b7f908caa9bb97606fcc7f4c245 (diff)
downloadstrongswan-fea5e716c47444c760b6103ef23f77c2120d891c.tar.bz2
strongswan-fea5e716c47444c760b6103ef23f77c2120d891c.tar.xz
- added missing ipsec.conf ipsec.conf.5
- existing ipsec.conf won't get overwritten anymore
Diffstat (limited to 'src/starter/Makefile.am')
-rw-r--r--src/starter/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/starter/Makefile.am b/src/starter/Makefile.am
index 48aa47f9b..fc088c37e 100644
--- a/src/starter/Makefile.am
+++ b/src/starter/Makefile.am
@@ -8,9 +8,8 @@ exec.h invokecharon.h lex.yy.c
INCLUDES = -I$(top_srcdir)/src/libfreeswan -I$(top_srcdir)/src/pluto -I$(top_srcdir)/src/whack -I$(top_srcdir)/src/stroke
AM_CFLAGS = -DIPSEC_DIR=\"${ipsecdir}\" -DIPSEC_CONFDIR=\"${confdir}\" -DIPSEC_PIDDIR=\"${piddir}\" -DDEBUG
starter_LDADD = loglite.o defs.o $(top_srcdir)/src/libfreeswan/libfreeswan.a
-EXTRA_DIST = parser.l parser.y keywords.txt
+EXTRA_DIST = parser.l parser.y keywords.txt ipsec.conf
man_MANS = ipsec.conf.5
-sysconf_DATA = ipsec.conf
PLUTODIR=$(top_srcdir)/src/pluto
OPENACDIR=$(top_srcdir)/src/openac
@@ -32,3 +31,8 @@ loglite.o: $(OPENACDIR)/loglite.c $(PLUTODIR)/log.h
defs.o: $(PLUTODIR)/defs.c $(PLUTODIR)/defs.h
$(CC) $(AM_CFLAGS) $(INCLUDES) -c -o $@ $<
+
+install-exec-local :
+ test -e "$(sysconfdir)/ipsec.conf" || $(INSTALL) ipsec.conf $(sysconfdir)/ipsec.conf
+
+