aboutsummaryrefslogtreecommitdiffstats
path: root/src/swanctl/Makefile.am
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-09-19 14:32:22 -0400
committerTobias Brunner <tobias@strongswan.org>2014-09-26 10:52:37 +0200
commit0efea2fd86e0d0ffb04628f4806ea313bc692f2a (patch)
tree0617be91bc776887279d813f56ef2cc8c59c939d /src/swanctl/Makefile.am
parent55e85387bb15400f45b91cdecbef52171789d78c (diff)
downloadstrongswan-0efea2fd86e0d0ffb04628f4806ea313bc692f2a.tar.bz2
strongswan-0efea2fd86e0d0ffb04628f4806ea313bc692f2a.tar.xz
Don't fail to install if sysconfdir isn't writable
Diffstat (limited to 'src/swanctl/Makefile.am')
-rw-r--r--src/swanctl/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/swanctl/Makefile.am b/src/swanctl/Makefile.am
index dec7d62ed..482688c97 100644
--- a/src/swanctl/Makefile.am
+++ b/src/swanctl/Makefile.am
@@ -56,7 +56,7 @@ maintainer-clean-local:
cd $(srcdir) && rm -f swanctl.conf swanctl.conf.5.main
install-data-local: swanctl.conf
- test -e "$(DESTDIR)$(swanctldir)" || $(INSTALL) -d "$(DESTDIR)$(swanctldir)"
+ test -e "$(DESTDIR)$(swanctldir)" || $(INSTALL) -d "$(DESTDIR)$(swanctldir)" || true
test -e "$(DESTDIR)$(swanctldir)/x509" || $(INSTALL) -d "$(DESTDIR)$(swanctldir)/x509" || true
test -e "$(DESTDIR)$(swanctldir)/x509ca" || $(INSTALL) -d "$(DESTDIR)$(swanctldir)/x509ca" || true
test -e "$(DESTDIR)$(swanctldir)/x509aa" || $(INSTALL) -d "$(DESTDIR)$(swanctldir)/x509aa" || true