aboutsummaryrefslogtreecommitdiffstats
path: root/src/charon/plugins/kernel_pfroute/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/charon/plugins/kernel_pfroute/Makefile.am')
-rw-r--r--src/charon/plugins/kernel_pfroute/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/charon/plugins/kernel_pfroute/Makefile.am b/src/charon/plugins/kernel_pfroute/Makefile.am
new file mode 100644
index 000000000..3ad445c09
--- /dev/null
+++ b/src/charon/plugins/kernel_pfroute/Makefile.am
@@ -0,0 +1,10 @@
+
+INCLUDES = -I${linuxdir} -I$(top_srcdir)/src/libstrongswan -I$(top_srcdir)/src/charon
+
+AM_CFLAGS = -rdynamic
+
+plugin_LTLIBRARIES = libstrongswan-kernel-pfroute.la
+
+libstrongswan_kernel_pfroute_la_SOURCES = kernel_pfroute_plugin.h kernel_pfroute_plugin.c \
+ kernel_pfroute_net.h kernel_pfroute_net.c
+libstrongswan_kernel_pfroute_la_LDFLAGS = -module