aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-03-29 04:25:22 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-03-29 04:25:22 +0000
commit0e6b05340ebf96de303f30fd5dae43ca584cf308 (patch)
tree73a87c321f5ecec97e7d873e2c37de0b1d85344e
parent8921616d87090b3a107458ea4a60ae645ab4f830 (diff)
downloadaports-0e6b05340ebf96de303f30fd5dae43ca584cf308.tar.bz2
aports-0e6b05340ebf96de303f30fd5dae43ca584cf308.tar.xz
main/x265: disable altivec on ppc64le
-rw-r--r--main/x265/APKBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/main/x265/APKBUILD b/main/x265/APKBUILD
index 0cf29787be..c12fa13a4c 100644
--- a/main/x265/APKBUILD
+++ b/main/x265/APKBUILD
@@ -32,6 +32,9 @@ build() {
if [ "$CARCH" = x86 ] ; then
CMAKE_OPS="$CMAKE_OPS -DENABLE_ASSEMBLY=OFF"
fi
+ if [ "$CARCH" = ppc64le ] ; then
+ CMAKE_OPS="$CMAKE_OPS -DENABLE_ALTIVEC=OFF"
+ fi
cmake -G "Unix Makefiles" $CMAKE_OPS ../../source
}