aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-06 17:26:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:15 +0000
commit3eba00134e6e1a9a6b16cf1d85cc598e1ce86a37 (patch)
tree34e1f95d398aa6d94400c042bf67ef29353134a2
parent9eb104950711db777f1b25a2fb39e0387017f31c (diff)
downloadaports-3eba00134e6e1a9a6b16cf1d85cc598e1ce86a37.tar.bz2
aports-3eba00134e6e1a9a6b16cf1d85cc598e1ce86a37.tar.xz
testing/mod_auth_cas: rebuild against openssl 1.1
-rw-r--r--testing/mod_auth_cas/APKBUILD28
-rw-r--r--testing/mod_auth_cas/openssl-1.1.patch13
2 files changed, 29 insertions, 12 deletions
diff --git a/testing/mod_auth_cas/APKBUILD b/testing/mod_auth_cas/APKBUILD
index 7ac07eb032..7c60a5c879 100644
--- a/testing/mod_auth_cas/APKBUILD
+++ b/testing/mod_auth_cas/APKBUILD
@@ -2,20 +2,28 @@
# Maintainer:
pkgname=mod_auth_cas
pkgver=1.1
-pkgrel=3
+pkgrel=4
pkgdesc="An Apache httpd module for integrating with Apereo (JASIG) CAS Server project"
url="https://www.apereo.org/projects/cas"
arch="all"
license="Apache"
depends=""
depends_dev=""
-makedepends="$depends_dev apache2-dev curl-dev pcre-dev"
+makedepends="$depends_dev apache2-dev curl-dev pcre-dev
+ autoconf automake libtool"
install=""
subpackages=""
source="mod_auth_cas-$pkgver.tar.gz::https://github.com/Jasig/mod_auth_cas/archive/v$pkgver.tar.gz
- remove-error.h.patch"
+ remove-error.h.patch
+ openssl-1.1.patch
+ "
builddir="$srcdir/mod_auth_cas-$pkgver"
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
build() {
cd "$builddir"
./configure \
@@ -24,19 +32,15 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="ee2e96b71d77fb7bd206d818f0c8a0bc mod_auth_cas-1.1.tar.gz
-d5ca3954d48cd678fd564b1f49de251d remove-error.h.patch"
-sha256sums="e70decc7a887c63df46a848497acdbd8fa4776d0c8a8c1de2c0d71b1b07e3dd0 mod_auth_cas-1.1.tar.gz
-828cbba809503d4feed94d1e1592e16c2c19d030f41cda53179a9bec6dde79c8 remove-error.h.patch"
sha512sums="39625df051494f55cdbf5d703b0b1f244da6bb4e1a0609869158675c773abcef135e77cef32b70b4e5d5a59f82ea963a95929ae3880e367664e37c8a942c723a mod_auth_cas-1.1.tar.gz
-7e0d9dd6022e8a6243ca8650e189d3ca2a35301d9966cb7e3a31b99348d6b2cd3c3f75910fd8ea891c9f5f0ba89d1a047223b72ebcd9844121228e5909868679 remove-error.h.patch"
+7e0d9dd6022e8a6243ca8650e189d3ca2a35301d9966cb7e3a31b99348d6b2cd3c3f75910fd8ea891c9f5f0ba89d1a047223b72ebcd9844121228e5909868679 remove-error.h.patch
+ffdd07f414cc8418bff68af85fd7b69c923288130b00742d85439f690bb6d90cec6f2fe3e61abaee035823acf0e6b46f54ce71dd8f2c0ee3582d6d7412db1a40 openssl-1.1.patch"
diff --git a/testing/mod_auth_cas/openssl-1.1.patch b/testing/mod_auth_cas/openssl-1.1.patch
new file mode 100644
index 0000000000..66c8802cfc
--- /dev/null
+++ b/testing/mod_auth_cas/openssl-1.1.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 72644f1..7d0f21d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -131,7 +131,7 @@ AC_SUBST(TEST_COVERAGE_CFLAGS)
+ AX_CHECK_OPENSSL
+
+ AC_CHECK_LIB([crypto],[CRYPTO_new_ex_data], [], [AC_MSG_ERROR([OpenSSL libraries required])])
+-AC_CHECK_LIB([ssl],[SSL_library_init], [], [AC_MSG_ERROR([OpenSSL libraries required])])
++AC_CHECK_LIB([ssl],[OPENSSL_init_ssl], [], [AC_MSG_ERROR([OpenSSL libraries required])])
+
+ AC_CHECK_HEADERS([openssl/crypto.h openssl/x509.h openssl/pem.h openssl/ssl.h openssl/err.h],[],[AC_MSG_ERROR([OpenSSL headers required])])
+