aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-28 07:01:20 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-30 12:58:22 +0000
commit529f7d454f589f120f2bcc1c2fd5eeb42afe324f (patch)
tree274daa00fc62ee1efb05a4b6f87a6056415c2dba
parent176cd41390663c0d842059b80e90dc3ef11e52e9 (diff)
downloadaports-529f7d454f589f120f2bcc1c2fd5eeb42afe324f.tar.bz2
aports-529f7d454f589f120f2bcc1c2fd5eeb42afe324f.tar.xz
main/redis: fix build on mips{el} (-latomic)
Note mipsel* not just mipsel is intentional to cover out-of-tree mipseln8hf.
-rw-r--r--main/redis/APKBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/main/redis/APKBUILD b/main/redis/APKBUILD
index 414fb597e9..51e27cc716 100644
--- a/main/redis/APKBUILD
+++ b/main/redis/APKBUILD
@@ -38,9 +38,11 @@ prepare() {
build() {
cd "$builddir"
+ case "$CARCH" in mips|mipsel*) _libatomic="-latomic";; esac
make PREFIX=/usr \
INSTALL_BIN="$pkgdir"/usr/bin \
MALLOC=libc \
+ FINAL_LIBS="-lm -ldl -pthread $_libatomic" \
all
}