aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-29 22:16:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-12 17:27:33 -0300
commit7bc4bdd42ba99561aea3e924cb13a43ce48a8fec (patch)
tree6c73e85dbe730b33b9759fd6c14e44ce9a0808b0
parent400dfa53d90e1cf5a41616898b3a276b9fddb284 (diff)
downloadaports-7bc4bdd42ba99561aea3e924cb13a43ce48a8fec.tar.bz2
aports-7bc4bdd42ba99561aea3e924cb13a43ce48a8fec.tar.xz
testing/py3-html: switch to python3
-rw-r--r--testing/py3-html/APKBUILD45
-rw-r--r--testing/py3-html/fix-install-py3.patch14
2 files changed, 33 insertions, 26 deletions
diff --git a/testing/py3-html/APKBUILD b/testing/py3-html/APKBUILD
index 48e77d0f7d..cef18c9b72 100644
--- a/testing/py3-html/APKBUILD
+++ b/testing/py3-html/APKBUILD
@@ -1,41 +1,34 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-html
+pkgname=py3-html
_pkgname=html
pkgver=1.16
-pkgrel=0
+pkgrel=1
pkgdesc="A Python HTML, XHTML, and XML generation module"
url="http://pypi.python.org/pypi/html"
arch="noarch"
-license="BSD"
-depends="python2"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+license="MIT"
+depends="python3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ fix-install-py3.patch
+ "
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-html" # Backwards compat
+provides="py-html=$pkgver-r$pkgrel" # Backwards compat
+
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
+}
+
+check() {
+ python3 -m html
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="39b9db7cdcc84607828be021172d441f html-1.16.tar.gz"
-sha256sums="ebc768f23b54a71350d731a75f2ef3a4a4dbdad9ae68d58b527664b66088e456 html-1.16.tar.gz"
-sha512sums="fe2329775bc9154aafe2411adb893ce443d3e0875cfa0efa9a722c068578713d3cc123fc62e732215766b3bf7371777a173969100f3025b9f9c99b504482ea39 html-1.16.tar.gz"
+sha512sums="fe2329775bc9154aafe2411adb893ce443d3e0875cfa0efa9a722c068578713d3cc123fc62e732215766b3bf7371777a173969100f3025b9f9c99b504482ea39 html-1.16.tar.gz
+98d5d4b6e0ff941f82de2a6f61ac1b8e0866195a28519957132c094c98bf8cf844528ba2f30e4996bc023862ab5c095695317034c908c634456d48d10bb2c041 fix-install-py3.patch"
diff --git a/testing/py3-html/fix-install-py3.patch b/testing/py3-html/fix-install-py3.patch
new file mode 100644
index 0000000000..1b8fd8d7c4
--- /dev/null
+++ b/testing/py3-html/fix-install-py3.patch
@@ -0,0 +1,14 @@
+diff --git a/setup.py b/setup.py
+index b201a7b..03942ec 100644
+--- a/setup.py
++++ b/setup.py
+@@ -9,7 +9,7 @@ setup(
+ name = "html",
+ version = __version__,
+ description = "simple, elegant HTML, XHTML and XML generation",
+- long_description = __doc__.decode('utf8'),
++ long_description = __doc__,
+ author = "Richard Jones",
+ author_email = "rjones@ekit-inc.com",
+ py_modules = ['html'],
+