aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 11:49:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 15:21:17 -0300
commit9f826870c6fb02f892ef24a5508a2c80b008c855 (patch)
tree8eab61300fa0174375b63fd43a1785c42ff041e8
parent615a5c6a121603e12fda8a25bd9b7c679e33f948 (diff)
downloadaports-9f826870c6fb02f892ef24a5508a2c80b008c855.tar.bz2
aports-9f826870c6fb02f892ef24a5508a2c80b008c855.tar.xz
community/fmt: upgrade to 6.0.0
-rw-r--r--community/fmt/0001-install-pkg-config-file-into-libdir.patch36
-rw-r--r--community/fmt/APKBUILD11
2 files changed, 4 insertions, 43 deletions
diff --git a/community/fmt/0001-install-pkg-config-file-into-libdir.patch b/community/fmt/0001-install-pkg-config-file-into-libdir.patch
deleted file mode 100644
index 46aa8cd439..0000000000
--- a/community/fmt/0001-install-pkg-config-file-into-libdir.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 693b64cd580e78b4c47b30720df11edec0fa8ff8 Mon Sep 17 00:00:00 2001
-From: Olaf Hering <olaf@aepfle.de>
-Date: Mon, 25 Mar 2019 17:16:18 +0100
-Subject: [PATCH] install pkg-config file into libdir
-
-Most pkgconfig files contain a Libs: variable, which is either /usr/lib
-or /usr/lib64. If a 32bit and a 64bit variant of fmt libraries is
-installed, the last one wins. As a result compiling for the other
-bitsize will fail.
-
-Instead of sharedir use libdir as install target.
-
-Fixes commit 9d0c9c4bb145a286f725cd38c90331eee7addc7f
-Fixes commit 287342dab10a5a96479b3e21cd11ce671ed8125c
-
-Signed-off-by: Olaf Hering <olaf@aepfle.de>
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ce9dbf95..6903a11c 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -205,7 +205,7 @@ if (FMT_INSTALL)
- set(FMT_INC_DIR ${CMAKE_INSTALL_INCLUDEDIR}/fmt CACHE STRING
- "Installation directory for include files, relative to ${CMAKE_INSTALL_PREFIX}.")
-
-- set(FMT_PKGCONFIG_DIR "${CMAKE_INSTALL_PREFIX}/share/pkgconfig" CACHE PATH
-+ set(FMT_PKGCONFIG_DIR ${CMAKE_INSTALL_LIBDIR}/pkgconfig CACHE PATH
- "Installation directory for pkgconfig (.pc) files, relative to ${CMAKE_INSTALL_PREFIX}.")
-
- # Generate the version, config and target files into the build directory.
---
-2.22.0
-
diff --git a/community/fmt/APKBUILD b/community/fmt/APKBUILD
index fb402aa026..77e80423b9 100644
--- a/community/fmt/APKBUILD
+++ b/community/fmt/APKBUILD
@@ -1,16 +1,15 @@
# Contributor: Luca Weiss <luca@z3ntu.xyz>
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname="fmt"
-pkgver="5.3.0"
+pkgver="6.0.0"
pkgrel=0
pkgdesc="Open-source formatting library for C++"
url="https://fmt.dev/latest/index.html"
arch="all"
-license="BSD-2-Clause"
+license="MIT"
makedepends="cmake doxygen"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/fmtlib/fmt/releases/download/$pkgver/fmt-$pkgver.zip
- 0001-install-pkg-config-file-into-libdir.patch"
+source="https://github.com/fmtlib/fmt/releases/download/$pkgver/fmt-$pkgver.zip"
options="!check" # 93% tests passed, 1 tests failed out of 14
build() {
@@ -23,7 +22,6 @@ build() {
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS" \
${CMAKE_CROSSOPTS} .
make
}
@@ -36,5 +34,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="3075553cb8200cf268e77339ccc7faf834f7af4dabaf5a7ddbb2de9969eb94e6d51e7ba943692e6be54e016907b72eb5e0d9b16a3873e52ff41596660b4f1186 fmt-5.3.0.zip
-75f5fdf0b3a47e5a31a608c14274e0c9d6f0600e0847f8607f4e62966c944ddbbed5ea3287b3f714e2ca56d242ca68bb68b5a1c77ca516a6e19033195d30c6b0 0001-install-pkg-config-file-into-libdir.patch"
+sha512sums="c2d458c341ded52c3df0ce4ad45e2acc4d486200e97feb53d08de7802c44ec2e0284dde2beccc27db72fdd7bd9f06413c977dc3de7184250d6853222a750bcc7 fmt-6.0.0.zip"