aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikhail Snetkov <ufoproger@gmail.com>2020-05-12 09:05:07 +0000
committerRasmus Thomsen <oss@cogitri.dev>2020-05-12 09:05:07 +0000
commitb0e3702a451ed619c3563a19335c3352e8013a44 (patch)
tree49f4bdf01b85bf5cd130b4e5977b2a9336a1b28a
parentd690fae986788ae1edd347da0b76e6e89813a55e (diff)
downloadaports-b0e3702a451ed619c3563a19335c3352e8013a44.tar.bz2
aports-b0e3702a451ed619c3563a19335c3352e8013a44.tar.xz
testing/lockrun: new aport
Run cron job with overrun protection http://unixwiz.net/tools/lockrun.html
-rw-r--r--testing/lockrun/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/lockrun/APKBUILD b/testing/lockrun/APKBUILD
new file mode 100644
index 0000000000..4c45bc312f
--- /dev/null
+++ b/testing/lockrun/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Mikhail Snetkov <msnetkov@navikey.ru>
+# Maintainer: Mikhail Snetkov <msnetkov@navikey.ru>
+pkgname=lockrun
+pkgver=1.1.3
+pkgrel=0
+pkgdesc="Run cron job with overrun protection"
+url="http://unixwiz.net/tools/lockrun.html"
+arch="all"
+license="Public-Domain"
+options="!check" # No test suite.
+source="http://unixwiz.net/tools/lockrun.c"
+
+build() {
+ gcc $CFLAGS lockrun.c -o lockrun $LDFLAGS
+}
+
+package() {
+ install -Dm775 "$srcdir/lockrun" "$pkgdir/usr/bin/lockrun"
+}
+
+sha512sums="e31177ac47ff810c1900d4f97a8620d48f67b2cac3f2a7df45985934e2446e3afe35f4fc82b0e5dc7dcbc676521ba96bd535f172b3b0abb0bc0f5a152f750b3a lockrun.c"