aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2019-11-22 17:38:10 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-11-22 16:57:47 +0000
commitbef5705e8d72500193792fb244bb846d3ec2528c (patch)
treebc794326688d8701ad35e733e9bec37aac98a1df
parent62b8d8bdb47f4b33d3569183ff9499aff3397939 (diff)
downloadaports-bef5705e8d72500193792fb244bb846d3ec2528c.tar.bz2
aports-bef5705e8d72500193792fb244bb846d3ec2528c.tar.xz
testing/geos: fix build on arm(hf|v7)
Closes !1555
-rw-r--r--testing/geos/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/testing/geos/APKBUILD b/testing/geos/APKBUILD
index 6e46436817..ded077193c 100644
--- a/testing/geos/APKBUILD
+++ b/testing/geos/APKBUILD
@@ -26,6 +26,13 @@ build() {
case "$CARCH" in
aarch64*|ppc64le) CXXFLAGS="$CXXFLAGS -ffp-contract=off" ;;
esac
+
+ # fix build on armhf and armv7 with info from
+ # https://trac.osgeo.org/geos/ticket/993
+ case "$CARCH" in
+ armhf|armv7) CXXFLAGS="$CXXFLAGS -DDISABLE_GEOS_INLINE=ON" ;;
+ esac
+
./configure \
--build=$CBUILD \
--host=$CHOST \