aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-20 12:52:56 +0300
committerprspkt <prspkt@protonmail.com>2019-06-20 12:53:03 +0300
commitc7441365d1389540baaec5047ef131208cbf0fc7 (patch)
tree3276d483981660e229811ef80614f9fe44651602
parenta81b76d802cde51dcd3b8854f1361046cc9a08b0 (diff)
downloadaports-c7441365d1389540baaec5047ef131208cbf0fc7.tar.bz2
aports-c7441365d1389540baaec5047ef131208cbf0fc7.tar.xz
testing/py-junit-xml: drop python2
-rw-r--r--testing/py3-junit-xml/APKBUILD (renamed from testing/py-junit-xml/APKBUILD)41
-rw-r--r--testing/py3-junit-xml/disable_failing_test.patch (renamed from testing/py-junit-xml/disable_failing_test.patch)0
2 files changed, 9 insertions, 32 deletions
diff --git a/testing/py-junit-xml/APKBUILD b/testing/py3-junit-xml/APKBUILD
index e3cbb43a65..91e0bc2065 100644
--- a/testing/py-junit-xml/APKBUILD
+++ b/testing/py3-junit-xml/APKBUILD
@@ -1,18 +1,16 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinx.org>
-pkgname=py-junit-xml
-_pkgname=${pkgname/py-}
+pkgname=py3-junit-xml
+_pkgname=junit-xml
pkgver=1.8
pkgrel=2
pkgdesc="Creates JUnit XML test result documents that can be read by tools such as Jenkins"
url="https://pypi.python.org/pypi/junit-xml"
arch="noarch"
license="MIT"
-depends=""
-makedepends="python2-dev python3-dev py2-setuptools"
-checkdepends="py-six"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://pypi.python.org/packages/a6/2a/f8d5aab80bb31fcc789d0f2b34b49f08bd6121cd8798d2e37f416df2b9f8/junit-xml-$pkgver.tar.gz
- disable_failing_test.patch"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-six"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
@@ -21,39 +19,18 @@ prepare() {
build() {
cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
check() {
cd "$builddir"
- python2 setup.py test
python3 setup.py test
}
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
+package() {
cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
+
sha512sums="8fcef94ea73a77ad597bb3280578f0fea86573b779eb4aea1e458e55f1866637a7b43aa04502a65ecb1f2a7403cc61a76ccd35feb4b69eeb6fdc8352914d61a4 junit-xml-1.8.tar.gz
af01b010c4272ebb3fedcbefe5d19c842976765575d35c3649ffb1dfa2313ea9638c6eef2e489651f164e1398b5f12954f15516ac339ef99a49a5d32120f5c4a disable_failing_test.patch"
diff --git a/testing/py-junit-xml/disable_failing_test.patch b/testing/py3-junit-xml/disable_failing_test.patch
index d52a32e6e2..d52a32e6e2 100644
--- a/testing/py-junit-xml/disable_failing_test.patch
+++ b/testing/py3-junit-xml/disable_failing_test.patch