aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-junit-xml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py3-junit-xml/APKBUILD')
-rw-r--r--testing/py3-junit-xml/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/py3-junit-xml/APKBUILD b/testing/py3-junit-xml/APKBUILD
new file mode 100644
index 0000000000..91e0bc2065
--- /dev/null
+++ b/testing/py3-junit-xml/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinx.org>
+pkgname=py3-junit-xml
+_pkgname=junit-xml
+pkgver=1.8
+pkgrel=2
+pkgdesc="Creates JUnit XML test result documents that can be read by tools such as Jenkins"
+url="https://pypi.python.org/pypi/junit-xml"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-six"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8fcef94ea73a77ad597bb3280578f0fea86573b779eb4aea1e458e55f1866637a7b43aa04502a65ecb1f2a7403cc61a76ccd35feb4b69eeb6fdc8352914d61a4 junit-xml-1.8.tar.gz
+af01b010c4272ebb3fedcbefe5d19c842976765575d35c3649ffb1dfa2313ea9638c6eef2e489651f164e1398b5f12954f15516ac339ef99a49a5d32120f5c4a disable_failing_test.patch"