aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMinecrell <minecrell@minecrell.net>2020-03-27 13:05:34 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2020-03-30 12:24:32 +0000
commitc7b36a0ad495a17d24dda952faacae63f7584e3a (patch)
treeacbc41a37e54e5a15c1712dc8ab7fa7fc6c329a2
parent2d66b57037c2555c2a67b4e48cb6489f8cfc4cb9 (diff)
downloadaports-c7b36a0ad495a17d24dda952faacae63f7584e3a.tar.bz2
aports-c7b36a0ad495a17d24dda952faacae63f7584e3a.tar.xz
community/libbpf: remove unneeded stddef patch, enable all arch
This was only needed because the swab.h header is broken in linux-headers. Also enable on all architectures since it seems to build just fine.
-rw-r--r--community/libbpf/10-include-stddef.patch12
-rw-r--r--community/libbpf/APKBUILD6
2 files changed, 2 insertions, 16 deletions
diff --git a/community/libbpf/10-include-stddef.patch b/community/libbpf/10-include-stddef.patch
deleted file mode 100644
index e3fe4d1a9c..0000000000
--- a/community/libbpf/10-include-stddef.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/libbpf.c b/src/libbpf.c
-index b38dcbe..bc3ac5d 100644
---- a/src/libbpf.c
-+++ b/src/libbpf.c
-@@ -29,6 +29,7 @@
- #include <linux/filter.h>
- #include <linux/list.h>
- #include <linux/limits.h>
-+#include <linux/stddef.h>
- #include <linux/perf_event.h>
- #include <linux/ring_buffer.h>
- #include <sys/stat.h>
diff --git a/community/libbpf/APKBUILD b/community/libbpf/APKBUILD
index 87bf5e72f2..b6a5e39364 100644
--- a/community/libbpf/APKBUILD
+++ b/community/libbpf/APKBUILD
@@ -1,10 +1,10 @@
# Maintainer: Adam Jensen <acjensen@gmail.com>
pkgname=libbpf
pkgver=0.0.7
-pkgrel=0
+pkgrel=1
pkgdesc="A library for interacting with the Linux kernel's Berkeley Packet Filter (BPF) facility from user space"
url="https://github.com/libbpf/libbpf"
-arch="aarch64 x86 x86_64 s390x"
+arch="all"
license="GPL-2.0-only"
# No test suite
options="!check"
@@ -12,7 +12,6 @@ depends="elfutils"
makedepends="build-base linux-headers elfutils-dev zlib-dev"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/libbpf/libbpf/archive/v$pkgver.tar.gz
- 10-include-stddef.patch
20-consolidate-lib-dirs.patch"
build() {
@@ -27,5 +26,4 @@ package() {
}
sha512sums="c2cbc869b7e11339deab3152a6e2d0b3bba25da513d18d77fb0a698cbe61d6bd48175a58e7dd7a3695fbf27faf48b4f517ac5d3a3c66c086df2e5d1b73a2595d libbpf-0.0.7.tar.gz
-946e445ffa4c5df42ebac77b7a1c6478b37dc7b55e0883aee195c6a8c4f8718b4dbf98b7c6d3016e1619e59440d8e4a76dad1e843114dfe2f9a2610e5cbb7943 10-include-stddef.patch
26f2b7bee6a11f2c9d4a36b5ee3cd2e85d65f496f0ce9ca49e561f2783ab95b56e23692d5de2364125bbdedd0d5978e884519e7d48131a06077d5578a4504b4a 20-consolidate-lib-dirs.patch"