aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-10-10 07:51:48 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-23 13:56:05 +0000
commitc95a086eb57a60904bee39b20bc7606f4786acc7 (patch)
tree0a874a1b5069eb222c10d1cc794cd4c41dbc592e
parent2594cf7077d7bbdfd03ea92bfb3ca4fb39c09b57 (diff)
downloadaports-c95a086eb57a60904bee39b20bc7606f4786acc7.tar.bz2
aports-c95a086eb57a60904bee39b20bc7606f4786acc7.tar.xz
community/emscripten-fastcomp: build fix for gcc8
The patch is taken from Fedora.
-rw-r--r--community/emscripten-fastcomp/APKBUILD9
-rw-r--r--community/emscripten-fastcomp/llvm-fix-return-type-in-ORC-readMem-client-interface.patch30
2 files changed, 36 insertions, 3 deletions
diff --git a/community/emscripten-fastcomp/APKBUILD b/community/emscripten-fastcomp/APKBUILD
index fdc5c25d9e..bdab4978a7 100644
--- a/community/emscripten-fastcomp/APKBUILD
+++ b/community/emscripten-fastcomp/APKBUILD
@@ -8,7 +8,7 @@
pkgname=emscripten-fastcomp
# Keep in sync with package emscripten!
pkgver=1.37.10
-pkgrel=1
+pkgrel=2
pkgdesc="The Clang + LLVM backend for Emscripten"
url="https://kripken.github.io/emscripten-site/"
arch="all"
@@ -18,7 +18,9 @@ makedepends="cmake paxmark zlib-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/kripken/$pkgname/archive/$pkgver.tar.gz
$pkgname-clang-$pkgver.tar.gz::https://github.com/kripken/$pkgname-clang/archive/$pkgver.tar.gz
llvm-fix-build-with-musl-libc.patch
- llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch"
+ llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
+ llvm-fix-return-type-in-ORC-readMem-client-interface.patch
+ "
builddir="$srcdir/$pkgname-$pkgver"
options="!check" # some tests are broken, don't bother with it for now
@@ -81,4 +83,5 @@ package() {
sha512sums="8a7ab29f2b239eef43bfcea3359847d9566aecd1252f6f27685e43bb71ef9031d3dffc14f07fdf97979461ea4e07140510aebec315ab4fdfaec9fcb944370c6a emscripten-fastcomp-1.37.10.tar.gz
54442b598001204420087b7ff6168c34a626e39a3992a343294cdc9c9a93020ca8de19365d15afc97d35ff94f584f50663e0b843696596f3ad3441608d974270 emscripten-fastcomp-clang-1.37.10.tar.gz
f84cd65d7042e89826ba6e8d48c4c302bf4980da369d7f19a55f217e51c00ca8ed178d453df3a3cee76598a7cecb94aed0775a6d24fe73266f82749913fc3e71 llvm-fix-build-with-musl-libc.patch
-19bfb9282455d39d07dbb2b1293b03a45c57d522fbb9c5e58dac034200669628b97e7a90cd4ff5d52d9bb79acfccbef653d8a1140a7f0589ecd6f9b7c4ba0eb6 llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch"
+19bfb9282455d39d07dbb2b1293b03a45c57d522fbb9c5e58dac034200669628b97e7a90cd4ff5d52d9bb79acfccbef653d8a1140a7f0589ecd6f9b7c4ba0eb6 llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
+f57c734687c8ceae8d1bbfcbfdeecb75a5059a112967f4ba639d78d2484e0cc1deabf02ba2d3a6f5283443bf8b3230f38ad143800f8f3327cca0d2691a3ddc3d llvm-fix-return-type-in-ORC-readMem-client-interface.patch"
diff --git a/community/emscripten-fastcomp/llvm-fix-return-type-in-ORC-readMem-client-interface.patch b/community/emscripten-fastcomp/llvm-fix-return-type-in-ORC-readMem-client-interface.patch
new file mode 100644
index 0000000000..5296fdb0ba
--- /dev/null
+++ b/community/emscripten-fastcomp/llvm-fix-return-type-in-ORC-readMem-client-interface.patch
@@ -0,0 +1,30 @@
+From 5cea35478aaaac7728a50cbafd3770f96162f7ac Mon Sep 17 00:00:00 2001
+From: Tilmann Scheller <tschelle@redhat.com>
+Date: Thu, 1 Feb 2018 11:40:01 -0600
+Subject: [PATCH] Fix return type in ORC readMem() client interface.
+
+GCC 8.0.1 detects the type mismatch and causes the compilation to fail. Clang
+and earlier versions of GCC don't detect the issue.
+
+Fixes rhbz#1540620.
+---
+ include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h b/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
+index da02250ba16..bed472e2e0e 100644
+--- a/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
++++ b/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
+@@ -713,8 +713,8 @@ private:
+
+ uint32_t getTrampolineSize() const { return RemoteTrampolineSize; }
+
+- Expected<std::vector<char>> readMem(char *Dst, JITTargetAddress Src,
+- uint64_t Size) {
++ Expected<std::vector<uint8_t>> readMem(char *Dst, JITTargetAddress Src,
++ uint64_t Size) {
+ // Check for an 'out-of-band' error, e.g. from an MM destructor.
+ if (ExistingError)
+ return std::move(ExistingError);
+--
+2.16.1