aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-12-21 18:42:57 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2019-12-21 18:44:04 +0100
commitf751ac10279ad1677402fb5f3635bb4f5f581456 (patch)
tree00c3b857424ce3d7435dfa18fb3d2020fe04e671
parent0be5b97ac2152464a07f62f7173c0ca2521ab419 (diff)
downloadaports-f751ac10279ad1677402fb5f3635bb4f5f581456.tar.bz2
aports-f751ac10279ad1677402fb5f3635bb4f5f581456.tar.xz
testing/bmake: unset MAKEFLAGS in check
This fixes the test failure on the builders.
-rw-r--r--testing/bmake/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/bmake/APKBUILD b/testing/bmake/APKBUILD
index 24924a31cc..c204b67014 100644
--- a/testing/bmake/APKBUILD
+++ b/testing/bmake/APKBUILD
@@ -17,7 +17,9 @@ build() {
}
check() {
- sh ./boot-strap op=test
+ # Unset MAKEFLAGS since it might contain options not supported
+ # by bmake. This is, for instance, the case on the builders.
+ env MAKEFLAGS= sh ./boot-strap op=test
}
package() {