aboutsummaryrefslogtreecommitdiffstats
path: root/community/editorconfig
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-17 19:54:37 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-17 19:55:25 +0100
commit7d188b54794413582e2f9fa4c387d1d2409faa56 (patch)
treee89d1b001528937674e3eaa31b89bfe196c27e9f /community/editorconfig
parent1a3cb52e95c7c248356d4bd71c7ea465366d3c11 (diff)
downloadaports-7d188b54794413582e2f9fa4c387d1d2409faa56.tar.bz2
aports-7d188b54794413582e2f9fa4c387d1d2409faa56.tar.xz
community/editorconfig: build with cmake profile MinSizeRel
Diffstat (limited to 'community/editorconfig')
-rw-r--r--community/editorconfig/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/community/editorconfig/APKBUILD b/community/editorconfig/APKBUILD
index ed53ca5094..58ca6c7cb2 100644
--- a/community/editorconfig/APKBUILD
+++ b/community/editorconfig/APKBUILD
@@ -17,7 +17,10 @@ build() {
cd "$builddir"
cmake . \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
+ -DCMAKE_C_FLAGS_MINSIZEREL="$CFLAGS" \
+ -DCMAKE_CXX_FLAGS_MINSIZEREL="$CXXFLAGS" \
+ -DCMAKE_EXE_LINKER_FLAGS_MINSIZEREL="$LDFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DINI_ALLOW_MULTILINE=1