aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-bluetooth/APKBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 12:11:12 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 12:11:12 +0100
commit37cca00fbe335d8c84d772d4ea3323fa204bcd71 (patch)
tree4275e1265c2a7cccc64e76beb2d5161b1818d2ca /community/gnome-bluetooth/APKBUILD
parentf27f694e518010617995ede72357067f1f9a6525 (diff)
downloadaports-37cca00fbe335d8c84d772d4ea3323fa204bcd71.tar.bz2
aports-37cca00fbe335d8c84d772d4ea3323fa204bcd71.tar.xz
main/gnome-bluetooth: move to community
Diffstat (limited to 'community/gnome-bluetooth/APKBUILD')
-rw-r--r--community/gnome-bluetooth/APKBUILD70
1 files changed, 70 insertions, 0 deletions
diff --git a/community/gnome-bluetooth/APKBUILD b/community/gnome-bluetooth/APKBUILD
new file mode 100644
index 0000000000..d09bb6bbc2
--- /dev/null
+++ b/community/gnome-bluetooth/APKBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnome-bluetooth
+pkgver=3.16.1
+pkgrel=1
+pkgdesc="The GNOME Bluetooth Subsystem"
+url="http://live.gnome.org/GnomeBluetooth"
+arch="all"
+license="GPL LGPL"
+depends="hicolor-icon-theme bluez>=5"
+makedepends="intltool py-gtk gobject-introspection-dev libunique-dev
+ libnotify-dev libxi-dev libxslt py-libxml2 gnome-doc-utils
+ dbus-glib-dev gtk+3.0-dev itstool eudev-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
+source="http://ftp.gnome.org/pub/GNOME/sources/gnome-bluetooth/${pkgver%.*}/gnome-bluetooth-$pkgver.tar.xz
+ 61-gnome-bluetooth-rfkill.rules
+ udev-hwdb.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ DATADIRNAME=share ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-desktop-update \
+ --disable-icon-update \
+ --disable-schemas-compile \
+ --enable-introspection \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -m644 -D "$srcdir/61-gnome-bluetooth-rfkill.rules" \
+ "$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules"
+}
+
+libs() {
+ default_libs
+ replaces="gnome-bluetooth"
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share/
+}
+
+md5sums="de7eb807e3ae913bca53917b195d9d9f gnome-bluetooth-3.16.1.tar.xz
+9fb6c8dcb5a3de3a953bf2ef42063e6e 61-gnome-bluetooth-rfkill.rules
+89830ec8b85689843c16b0751cad2959 udev-hwdb.patch"
+sha256sums="3feb202d6780a53bc4a570eab5b0179f9351b32c1d3f28151ac2d222453ae08b gnome-bluetooth-3.16.1.tar.xz
+b8acb8ea2e7f3588575cffd8ea14ec50c8641f518f2ea899771a508b299ea474 61-gnome-bluetooth-rfkill.rules
+3d8547e186235a030bc3b3c54d1fb403a6515d405d260a4c0d6947321dca6a4d udev-hwdb.patch"
+sha512sums="811db04e1ab91585031e86cb55ee7764b0f0dfd88682afaee2e67f99af12619c540a48a3879afd8fb66e39cb35917f637b637e4b6f3ab8b8e908351426b77576 gnome-bluetooth-3.16.1.tar.xz
+80b7fd0bc3e0f82c8d2d609ffed634200e63f61d9a134445df8e8511756b7fb423d338a1d12e42b91c57243097beaa3d4662856ec0507fb19a29b6de7ee9e4de 61-gnome-bluetooth-rfkill.rules
+4b991b89a4ea3bb3997016d2028cc8239c127b2b57eea8ad9bfda1265b3370f712daf6a42868c0c357fc5cd3cded350e1a56d90f64390cb8960905329b76879c udev-hwdb.patch"