aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-08-19 19:56:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-08-19 19:56:28 +0000
commita23f83bd23edd5e524775800cd17b5da8ed9cb96 (patch)
tree6555e4e8118e26b49347b8b49fc867bb03c84eec /community/go
parent3973cebebe48a1f158cf1f3fc884bb4510412408 (diff)
downloadaports-a23f83bd23edd5e524775800cd17b5da8ed9cb96.tar.bz2
aports-a23f83bd23edd5e524775800cd17b5da8ed9cb96.tar.xz
community/go: minor cleanup
we need the arm bootstrap binary explicitly in source so abuild does not complain about the extra checksum. also remove paxmark from makedepends as its no longer used.
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 5352bf49a4..0f07597c90 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -11,13 +11,14 @@ arch="all"
license="BSD"
depends=""
depends_dev=""
-makedepends="bash paxmark"
+makedepends="bash"
options="!strip"
install=""
subpackages="$pkgname-doc $pkgname-tools $pkgname-cross"
source="http://golang.org/dl/go${pkgver/_/}.src.tar.gz
$pkgname-tools-${pkgver/_/}.tar.gz::https://github.com/golang/tools/archive/${_toolsver}.tar.gz
default-buildmode-pie.patch
+ http://dev.alpinelinux.org/bootstrap/go/go-linux-musl-arm64-bootstrap.tar.bz2
"
# NOTE: building go for x86 with grsec kernel requires:
@@ -26,13 +27,12 @@ source="http://golang.org/dl/go${pkgver/_/}.src.tar.gz
# use go-bootstrap for archs that are supported
case "$CARCH" in
aarch64)
-source="$source http://dev.alpinelinux.org/bootstrap/go/go-linux-musl-arm64-bootstrap.tar.bz2"
-_goroot_bootstrap="$srcdir"/go-linux-arm64-bootstrap
-;;
+ _goroot_bootstrap="$srcdir"/go-linux-arm64-bootstrap
+ ;;
*)
-makedepends="$makedepends go-bootstrap"
-_goroot_bootstrap=/usr/lib/go-bootstrap
-;;
+ makedepends="$makedepends go-bootstrap"
+ _goroot_bootstrap=/usr/lib/go-bootstrap
+ ;;
esac
_gotools="cover godoc stringer"