aboutsummaryrefslogtreecommitdiffstats
path: root/community/inkscape
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-26 05:27:47 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-11-08 08:45:36 +0000
commitfee6ba0f5ed398e4d1bcf155c8127bd63a14ff38 (patch)
tree77f2ee77adce8a091b8452d9499e199bade6737b /community/inkscape
parentb2c2f1921e61cedca23e359ac2bbf2d5c71dcc17 (diff)
downloadaports-fee6ba0f5ed398e4d1bcf155c8127bd63a14ff38.tar.bz2
aports-fee6ba0f5ed398e4d1bcf155c8127bd63a14ff38.tar.xz
rebuild against libpoppler.so.92
Closes !846
Diffstat (limited to 'community/inkscape')
-rw-r--r--community/inkscape/APKBUILD9
-rw-r--r--community/inkscape/poppler-082.patch41
2 files changed, 47 insertions, 3 deletions
diff --git a/community/inkscape/APKBUILD b/community/inkscape/APKBUILD
index 163c28dbe5..a3eb3325b8 100644
--- a/community/inkscape/APKBUILD
+++ b/community/inkscape/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=inkscape
pkgver=0.92.4
-pkgrel=3
+pkgrel=4
pkgdesc="A vector-based drawing program - svg compliant"
url="https://inkscape.org/"
arch="all"
@@ -27,7 +27,9 @@ makedepends="
depends="desktop-file-utils"
checkdepends="bash py-lxml py-numpy>=1.14.3-r1"
subpackages="$pkgname-doc $pkgname-lang $pkgname-view"
-source="https://launchpad.net/inkscape/${pkgver%.*}.x/$pkgver/+download/inkscape-$pkgver.tar.bz2"
+source="https://launchpad.net/inkscape/${pkgver%.*}.x/$pkgver/+download/inkscape-$pkgver.tar.bz2
+ poppler-082.patch
+ "
options="!check" # cxxtest hangs at least on x86_64
builddir="$srcdir/$pkgname-$pkgver"
@@ -87,4 +89,5 @@ doc() {
"$subpkgdir"/usr/share/inkscape
}
-sha512sums="b9034605a79cd8aea808edf42e284819951ae1ea67778f0922f4c10224e94aca6c844acbc2294625773f0a7047d4e32ccdada876238a792a2c17db172c88e120 inkscape-0.92.4.tar.bz2"
+sha512sums="b9034605a79cd8aea808edf42e284819951ae1ea67778f0922f4c10224e94aca6c844acbc2294625773f0a7047d4e32ccdada876238a792a2c17db172c88e120 inkscape-0.92.4.tar.bz2
+adf360e99aaf2635a227bd3b59e03db688eef4713858cfbae2f02ed6368d4314cd490f53da3126555d6fc9a2b28072137c79169c18515331acd83ca643287432 poppler-082.patch"
diff --git a/community/inkscape/poppler-082.patch b/community/inkscape/poppler-082.patch
new file mode 100644
index 0000000000..69b8b5414b
--- /dev/null
+++ b/community/inkscape/poppler-082.patch
@@ -0,0 +1,41 @@
+diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp
+index c52675e..0b9ba15 100644
+--- a/src/extension/internal/pdfinput/pdf-parser.cpp
++++ b/src/extension/internal/pdfinput/pdf-parser.cpp
+@@ -2414,7 +2414,7 @@ void PdfParser::doShowText(GooString *s) {
+ int wMode;
+ double riseX, riseY;
+ CharCode code;
+- Unicode *u = NULL;
++ const Unicode *u = NULL;
+ double x, y, dx, dy, tdx, tdy;
+ double originX, originY, tOriginX, tOriginY;
+ double oldCTM[6], newCTM[6];
+
+diff --git a/src/extension/internal/pdfinput/svg-builder.cpp b/src/extension/internal/pdfinput/svg-builder.cpp
+index dd5e710..036fc70 100644
+--- a/src/extension/internal/pdfinput/svg-builder.cpp
++++ b/src/extension/internal/pdfinput/svg-builder.cpp
+@@ -1379,7 +1379,7 @@ void SvgBuilder::beginString(GfxState *state) {
+ void SvgBuilder::addChar(GfxState *state, double x, double y,
+ double dx, double dy,
+ double originX, double originY,
+- CharCode /*code*/, int /*nBytes*/, Unicode *u, int uLen) {
++ CharCode /*code*/, int /*nBytes*/, const Unicode *u, int uLen) {
+
+
+ bool is_space = ( uLen == 1 && u[0] == 32 );
+diff --git a/src/extension/internal/pdfinput/svg-builder.h b/src/extension/internal/pdfinput/svg-builder.h
+index 34b42e1..6fe62cc 100644
+--- a/src/extension/internal/pdfinput/svg-builder.h
++++ b/src/extension/internal/pdfinput/svg-builder.h
+@@ -141,7 +141,7 @@ public:
+ void addChar(GfxState *state, double x, double y,
+ double dx, double dy,
+ double originX, double originY,
+- CharCode code, int nBytes, Unicode *u, int uLen);
++ CharCode code, int nBytes, const Unicode *u, int uLen);
+ void beginTextObject(GfxState *state);
+ void endTextObject(GfxState *state);
+
+