aboutsummaryrefslogtreecommitdiffstats
path: root/community/mongodb
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2018-12-07 09:45:48 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2018-12-07 09:46:48 +0000
commitcdf7164858162572092e1c9e73cd946b6ed43d31 (patch)
tree75248a583cbf9b5c2d4fec8f6118b6e4473c5ba8 /community/mongodb
parentb38a11ee1f5109ffc2f67afa52903b9437dd4111 (diff)
downloadaports-cdf7164858162572092e1c9e73cd946b6ed43d31.tar.bz2
aports-cdf7164858162572092e1c9e73cd946b6ed43d31.tar.xz
community/mongodb: enable on aarch64
ref #9735
Diffstat (limited to 'community/mongodb')
-rw-r--r--community/mongodb/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/mongodb/APKBUILD b/community/mongodb/APKBUILD
index 1de045bc9c..74061f23f6 100644
--- a/community/mongodb/APKBUILD
+++ b/community/mongodb/APKBUILD
@@ -3,9 +3,9 @@
pkgname=mongodb
pkgver=4.0.4
pkgrel=0
-pkgdesc='A high-performance, open source, schema-free document-oriented database'
-url='http://www.mongodb.org'
-arch='x86_64 ppc64le'
+pkgdesc="A high-performance, open source, schema-free document-oriented database"
+url="http://www.mongodb.org"
+arch="x86_64 ppc64le aarch64"
options="!check" # out of disk space (>35GB)
license='AGPL3'
pkgusers="mongodb"
@@ -44,9 +44,12 @@ _buildopts="
--ssl \
"
+case $CARCH in
+ aarch64) _buildopts="$_buildopts CCFLAGS=-march=armv8-a+crc" ;;
+esac
+
build() {
cd "$builddir"
-
export SCONSFLAGS="$MAKEFLAGS"
scons $_buildopts --prefix=$pkgdir/usr core
}