aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-carp-assert
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-03-23 00:52:41 +0000
committerRasmus Thomsen <oss@cogitri.dev>2020-03-23 09:47:46 +0000
commitff92bd14c514acc3177216b571a5932f89f6bae7 (patch)
tree1648b56c7b548413801655f2d805c22d5c98440a /community/perl-carp-assert
parentf15e69c4cb78de9c55d88893e420461cb734da8b (diff)
downloadaports-ff92bd14c514acc3177216b571a5932f89f6bae7.tar.bz2
aports-ff92bd14c514acc3177216b571a5932f89f6bae7.tar.xz
community/perl-carp-assert: move from testing and modernize
Diffstat (limited to 'community/perl-carp-assert')
-rw-r--r--community/perl-carp-assert/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/perl-carp-assert/APKBUILD b/community/perl-carp-assert/APKBUILD
new file mode 100644
index 0000000000..317acea5d0
--- /dev/null
+++ b/community/perl-carp-assert/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-carp-assert
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Carp-Assert
+pkgver=0.21
+pkgrel=3
+pkgdesc="Perl module for executable comments"
+url="https://metacpan.org/release/Carp-Assert/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/N/NE/NEILB/Carp-Assert-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="9fb96ebaf03a86edcd0262b5216b345839dc99e504738e52f883932e425cac33470fcb0e8e4653488c0d8e63e9904af311056213c63ae40bc3935eec4c0410a0 Carp-Assert-0.21.tar.gz"