aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-requests-toolbelt
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-29 14:52:39 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 17:37:21 -0300
commita5d575e06eb6f18923fcd6aceca2b62ad51a6f15 (patch)
treea7fedb28f3cbafe6e4b89e0b12851420aca6306a /community/py3-requests-toolbelt
parent3f719de297b91f906200ae367526850c64d2b193 (diff)
downloadaports-a5d575e06eb6f18923fcd6aceca2b62ad51a6f15.tar.bz2
aports-a5d575e06eb6f18923fcd6aceca2b62ad51a6f15.tar.xz
community/py3-requests-toolbelt: upgrade to 0.9.1
Diffstat (limited to 'community/py3-requests-toolbelt')
-rw-r--r--community/py3-requests-toolbelt/APKBUILD42
1 files changed, 10 insertions, 32 deletions
diff --git a/community/py3-requests-toolbelt/APKBUILD b/community/py3-requests-toolbelt/APKBUILD
index ba196f1592..569873afa4 100644
--- a/community/py3-requests-toolbelt/APKBUILD
+++ b/community/py3-requests-toolbelt/APKBUILD
@@ -1,52 +1,30 @@
# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
-pkgname=py-requests-toolbelt
+pkgname=py3-requests-toolbelt
_pkgname=toolbelt
-pkgver=0.8.0
-pkgrel=1
+pkgver=0.9.1
+pkgrel=0
pkgdesc="Useful classes and functions to be used with python-requests"
+options="!check" # Requires unpackaged 'betamax' module
url="https://github.com/requests/toolbelt"
arch="noarch"
license="Apache-2.0"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+depends="py3-requests"
+makedepends="py3-setuptools"
+checkdepends="py3-mock py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://github.com/requests/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
- cd "$builddir"
- python2 setup.py check
- python3 setup.py check
+ python3 -m pytest
}
package() {
- cd "$builddir"
- mkdir -p "$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc ($python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-sha512sums="55bf93d386442f5deb81eabd85812ffd49e98ff88c0bb96e15271efd84deb7c5d854a2cdc81c989a7d74870e8a218fc968d080052d9ca7cd9733a2378ea9c2f5 py-requests-toolbelt-0.8.0.tar.gz"
+sha512sums="12667056c225ce0bc88a5959660103feed23810890abd3890ef15581aa64c09c0552c3974473e1742cbe6200bd37d6475ad34ec051e83d4fbf0a33f320dbc0cc py3-requests-toolbelt-0.9.1.tar.gz"