aboutsummaryrefslogtreecommitdiffstats
path: root/community/restic
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-14 15:29:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-14 15:29:13 -0300
commitb5a69b97f9d03109eb8fbf12140905c96ceecbbd (patch)
tree74ed031e1464aa43b215682810e80fabe5f471f1 /community/restic
parentd6a4eaf6ca65401689aa4765cf3c2042a3fcd89d (diff)
downloadaports-b5a69b97f9d03109eb8fbf12140905c96ceecbbd.tar.bz2
aports-b5a69b97f9d03109eb8fbf12140905c96ceecbbd.tar.xz
community/*: remove invalid options and modernize
Diffstat (limited to 'community/restic')
-rw-r--r--community/restic/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/community/restic/APKBUILD b/community/restic/APKBUILD
index f72df0f61b..d20d47a8ce 100644
--- a/community/restic/APKBUILD
+++ b/community/restic/APKBUILD
@@ -8,11 +8,11 @@ url="https://restic.net/"
arch="all"
license="BSD-2-Clause"
makedepends="go"
-options="net !checkroot"
+options="net"
subpackages="$pkgname-doc
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
-source="https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/restic/restic/releases/download/v$pkgver/restic-$pkgver.tar.gz"
builddir="$srcdir/src/github.com/$pkgname/$pkgname"
export GOPATH="$srcdir"
@@ -24,17 +24,14 @@ prepare() {
}
build() {
- cd "$builddir"
go build ./cmd/...
}
check() {
- cd "$builddir"
RESTIC_TEST_FUSE=0 make test
}
package() {
- cd "$builddir"
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
local man