aboutsummaryrefslogtreecommitdiffstats
path: root/community/rippled
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-02-20 18:36:20 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-02-21 18:12:22 +0100
commitc7a1f20490e2882233bfdfa682040d3cb0ffd967 (patch)
treea2b7e4154d67dc0ad64867ff7507b2883604688b /community/rippled
parent20b13d17d07ee2958a377d95f3ad14826ff9ddf9 (diff)
downloadaports-c7a1f20490e2882233bfdfa682040d3cb0ffd967.tar.bz2
aports-c7a1f20490e2882233bfdfa682040d3cb0ffd967.tar.xz
community/*: make CMake and meson respect our C{,PP,XX}FLAGS
See: https://lists.alpinelinux.org/~alpine/devel/%3C2896c13070c508a49cbaa72c8fb7f34ea947358b.camel%40cogitri.dev%3E
Diffstat (limited to 'community/rippled')
-rw-r--r--community/rippled/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/rippled/APKBUILD b/community/rippled/APKBUILD
index 2be18b34c3..049cc99e3b 100644
--- a/community/rippled/APKBUILD
+++ b/community/rippled/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=rippled
pkgver=1.3.1
-pkgrel=3
+pkgrel=4
pkgdesc="Blockchain daemon implementing the Ripple Consensus Ledger"
options="!check" # FIXME: 1 failure, rippled testsuite doesn't tell which one it is
url="https://ripple.com/"
@@ -17,7 +17,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/ripple/rippled/archive/$pkgv
build() {
mkdir build && cd build
- cmake .. -Dstatic=OFF -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
+ cmake .. -Dstatic=OFF -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=None
cmake --build .
}