aboutsummaryrefslogtreecommitdiffstats
path: root/community/unison/makefile-fix-clean.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-09 22:42:40 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-10 02:17:25 +0100
commit74ff07c2c66e578127fefde3120bc8ae8268f151 (patch)
tree4992fd1e1c81ffc2c0b130d21a70009393dbdf29 /community/unison/makefile-fix-clean.patch
parentd7643405faad0171da012b68b6c89702f5f6acb7 (diff)
downloadaports-74ff07c2c66e578127fefde3120bc8ae8268f151.tar.bz2
aports-74ff07c2c66e578127fefde3120bc8ae8268f151.tar.xz
community/unison: upgrade to 2.48.15v4, remove -doc
HTML page for this version is not available.
Diffstat (limited to 'community/unison/makefile-fix-clean.patch')
-rw-r--r--community/unison/makefile-fix-clean.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/unison/makefile-fix-clean.patch b/community/unison/makefile-fix-clean.patch
new file mode 100644
index 0000000000..1b584d0f47
--- /dev/null
+++ b/community/unison/makefile-fix-clean.patch
@@ -0,0 +1,25 @@
+$(FSMONITOR) starts with a hyphen, so it's interpreted as an option.
+$(NAME) is empty, so -blob is interpreted as an option.
+
+--- a/fsmonitor/linux/Makefile
++++ b/fsmonitor/linux/Makefile
+@@ -26,4 +26,4 @@
+
+ clean::
+ rm -f $(DIR)/*.cm[iox] $(DIR)/*.o $(DIR)/*~
+- rm -f $(FSMONITOR)$(EXEC_EXT)
+\ No newline at end of file
++ rm -f -- $(FSMONITOR)$(EXEC_EXT)
+--- a/Makefile
++++ b/Makefile
+@@ -354,8 +354,8 @@
+ clean::
+ -$(RM) *.log *.aux *.log *.dvi *.out *.bak
+ -$(RM) -r obsolete
+- -$(RM) $(NAME) $(NAME).exe
+- -$(RM) $(NAME)-blob.o
++ -$(RM) -- $(NAME) $(NAME).exe
++ -$(RM) -- $(NAME)-blob.o
+
+ clean::
+ $(MAKE) -C ubase clean