aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorMatthias Neugebauer <mtneug@mailbox.org>2019-03-21 17:55:24 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-23 16:28:31 +0000
commit3105f51a0f3482228c39a8cc49c27a2a4d7567d8 (patch)
tree963d17501b95121bc267282f4903ba2488689942 /community
parent34d0d870b08bf6accead030e307352a5353a816d (diff)
downloadaports-3105f51a0f3482228c39a8cc49c27a2a4d7567d8.tar.bz2
aports-3105f51a0f3482228c39a8cc49c27a2a4d7567d8.tar.xz
testing/go-bindata-assetfs: move to community
Diffstat (limited to 'community')
-rw-r--r--community/go-bindata-assetfs/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/go-bindata-assetfs/APKBUILD b/community/go-bindata-assetfs/APKBUILD
new file mode 100644
index 0000000000..8de2202a21
--- /dev/null
+++ b/community/go-bindata-assetfs/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Matthias Neugebauer <mtneug@mailbox.org>
+# Maintainer: Matthias Neugebauer <mtneug@mailbox.org>
+pkgname=go-bindata-assetfs
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="A small utility which generates Go code to serve any file with net/http"
+url="https://github.com/elazarl/go-bindata-assetfs"
+arch="all"
+license="BSD-2-Clause"
+depends="go-bindata"
+makedepends="go"
+options="!check" # no test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/elazarl/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/src/github.com/elazarl/$pkgname"
+
+prepare() {
+ default_prepare
+ mkdir -p "$srcdir/src/github.com/elazarl"
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+}
+
+build() {
+ cd "$builddir"
+
+ GOPATH="$srcdir" CGO_ENABLED=0 go build -v -o bin/$pkgname ./go-bindata-assetfs
+}
+
+package() {
+ install -Dm 755 "$builddir/bin/$pkgname" \
+ "$pkgdir/usr/bin/$pkgname"
+}
+
+sha512sums="009111511b10b14e83b166eaf37c36e6fc96097770cd6b1865d034f4e90cc3232930b6f5591ee1a960af46d76a7456a96dcc2ccc112234cb0d382a9f9cc575c2 go-bindata-assetfs-1.0.0.tar.gz"