aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-06 12:43:12 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-06 13:08:54 +0100
commitf5bc81a22091f5850c6fbef06bed800b110c8f79 (patch)
treec0cce53823e87670f21f8c053a4abc13b37d1f1a /community
parent9dfd1a4e27b2cc60755502c439b1b9fde00da55e (diff)
downloadaports-f5bc81a22091f5850c6fbef06bed800b110c8f79.tar.bz2
aports-f5bc81a22091f5850c6fbef06bed800b110c8f79.tar.xz
community/gnote: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/gnote/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/gnote/APKBUILD b/community/gnote/APKBUILD
new file mode 100644
index 0000000000..8bafc3d84a
--- /dev/null
+++ b/community/gnote/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gnote
+pkgver=3.34.1
+pkgrel=0
+pkgdesc="https://wiki.gnome.org/Apps/Gnote"
+url="Gnote is a port of Tomboy to C++"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="gtk+3.0-dev glibmm-dev gtkmm3-dev libsecret-dev gspell-dev
+ libxslt-dev util-linux-dev intltool itstool desktop-file-utils"
+options="!check" # missing dep: unittestcpp
+subpackages="$pkgname-lang $pkgname-doc"
+source="https://download.gnome.org/sources/gnote/${pkgver%.*}/gnote-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="6e9a76346e4da968fd627e85d27d45bb29b01a8a2f72a901a53add87d46c4aacdcf94c689954fce8d0ea5c6aa8b3208999a68b9a35e09fae00aca5917841c5fb gnote-3.34.1.tar.xz"