aboutsummaryrefslogtreecommitdiffstats
path: root/main/atk
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-30 14:54:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-07 10:13:47 +0100
commit78d37d9942be8548da47259a8b0f5ea584ed1f16 (patch)
treec071a4c1c2581c76002b213923520dff8a2f90d1 /main/atk
parent92116a4678aa9557f35ec994424bb86ce1e21626 (diff)
downloadaports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.bz2
aports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.xz
tree-wide: use --buildtype=debugoptimized for meson packages
As of now we're using the buildttype 'release', which produces optimized builds but without any usable debugging info, which makes debugging crashes impossible, even if a -dbg subpackage exists. As such we should build in the buildmode 'debugoptimized' to offer proper debug symbols.
Diffstat (limited to 'main/atk')
-rw-r--r--main/atk/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/atk/APKBUILD b/main/atk/APKBUILD
index 6c7851083c..4e8d0b7309 100644
--- a/main/atk/APKBUILD
+++ b/main/atk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=atk
pkgver=2.34.1
-pkgrel=0
+pkgrel=1
pkgdesc="A library providing a set of interfaces for accessibility"
url="https://www.gtk.org/"
arch="all"
@@ -15,9 +15,9 @@ build() {
cd "$builddir"
meson \
--prefix=/usr \
- --buildtype=release \
+ --buildtype=debugoptimized \
--sysconfdir=/etc \
- --buildtype=release \
+ --buildtype=debugoptimized \
-Ddocs=true \
output .
ninja -C output