aboutsummaryrefslogtreecommitdiffstats
path: root/main/ccache
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2018-01-20 14:22:57 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-01-20 17:46:46 +0100
commitad1e7fcc90bc8cd3f50b84e64ea2f9ee21835549 (patch)
tree877916377cc5c20ab4e7a60ccc26170b8e1c8dea /main/ccache
parent14351ecc2e8c23537602bca4d775f31dbe388260 (diff)
downloadaports-ad1e7fcc90bc8cd3f50b84e64ea2f9ee21835549.tar.bz2
aports-ad1e7fcc90bc8cd3f50b84e64ea2f9ee21835549.tar.xz
main/ccache: add check
Diffstat (limited to 'main/ccache')
-rw-r--r--main/ccache/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/ccache/APKBUILD b/main/ccache/APKBUILD
index 8530b638c2..6fb0957cd2 100644
--- a/main/ccache/APKBUILD
+++ b/main/ccache/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ccache
pkgver=3.3.5
-pkgrel=0
+pkgrel=1
pkgdesc="A fast C/C++ compiler cache"
url="http://ccache.samba.org/"
arch="all"
@@ -31,6 +31,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
install -Dm 755 ccache "$pkgdir"/usr/bin/ccache