aboutsummaryrefslogtreecommitdiffstats
path: root/main/curl
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-05-16 14:59:40 +0000
committerJakub Jirutka <jakub@jirutka.cz>2018-05-20 21:33:14 +0200
commit4fe999485632f6148040c631013587bd6c1c5e8b (patch)
tree55e6499718c3eff61d328873fd7cac3cd0908da9 /main/curl
parent0a8c160f5bfb61a52f6baa67dd5ce1e6b72038ae (diff)
downloadaports-4fe999485632f6148040c631013587bd6c1c5e8b.tar.bz2
aports-4fe999485632f6148040c631013587bd6c1c5e8b.tar.xz
main/curl: improve abuild
Diffstat (limited to 'main/curl')
-rw-r--r--main/curl/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index bab6aa18fd..641d86c521 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -6,16 +6,17 @@ pkgname=curl
pkgver=7.60.0
pkgrel=0
pkgdesc="URL retrival utility and library"
-url="http://curl.haxx.se"
+url="https://curl.haxx.se"
arch="all"
license="MIT"
depends="ca-certificates"
-depends_dev="zlib-dev libressl-dev libssh2-dev nghttp2-dev"
-makedepends="$depends_dev groff perl automake autoconf libtool"
+depends_dev="libressl-dev libssh2-dev nghttp2-dev zlib-dev"
+makedepends="$depends_dev autoconf automake groff libtool perl"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl"
-source="http://curl.haxx.se/download/$pkgname-$pkgver.tar.xz
+source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.xz
0001-openssl-fix-build-with-libressl-2.7.patch
"
+builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 7.60.0-r0:
@@ -67,8 +68,6 @@ source="http://curl.haxx.se/download/$pkgname-$pkgver.tar.xz
# - CVE-2014-0138
# - CVE-2014-0139
-builddir="$srcdir/$pkgname-$pkgver"
-
build() {
cd "$builddir"
autoreconf -vif
@@ -93,12 +92,13 @@ check() {
}
package() {
- make DESTDIR="$pkgdir" \
- -C "$builddir" install
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
}
libcurl() {
pkgdesc="The multiprotocol file transfer library"
+
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/lib "$subpkgdir"/usr
}