aboutsummaryrefslogtreecommitdiffstats
path: root/main/dconf
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-30 14:54:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-07 10:13:47 +0100
commit78d37d9942be8548da47259a8b0f5ea584ed1f16 (patch)
treec071a4c1c2581c76002b213923520dff8a2f90d1 /main/dconf
parent92116a4678aa9557f35ec994424bb86ce1e21626 (diff)
downloadaports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.bz2
aports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.xz
tree-wide: use --buildtype=debugoptimized for meson packages
As of now we're using the buildttype 'release', which produces optimized builds but without any usable debugging info, which makes debugging crashes impossible, even if a -dbg subpackage exists. As such we should build in the buildmode 'debugoptimized' to offer proper debug symbols.
Diffstat (limited to 'main/dconf')
-rw-r--r--main/dconf/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/dconf/APKBUILD b/main/dconf/APKBUILD
index b42e830632..3dd439a8b2 100644
--- a/main/dconf/APKBUILD
+++ b/main/dconf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=dconf
pkgver=0.34.0
-pkgrel=1
+pkgrel=2
pkgdesc="A low-level configuration system."
url="https://wiki.gnome.org/Projects/dconf"
arch="all"
@@ -18,7 +18,7 @@ build() {
meson \
--prefix=/usr \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
. output
ninja -C output
}