aboutsummaryrefslogtreecommitdiffstats
path: root/main/ebtables/fix-extension-init.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-05-21 07:38:51 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-05-21 07:39:37 +0000
commitfb228c4f93d8fe9217bf329087c4f16b8d54b709 (patch)
tree12f5838e16014626fe60dd59bfd25178b36b229e /main/ebtables/fix-extension-init.patch
parenta8fe31ad9e06b312b24d2d65b3844b971f3c2c94 (diff)
downloadaports-fb228c4f93d8fe9217bf329087c4f16b8d54b709.tar.bz2
aports-fb228c4f93d8fe9217bf329087c4f16b8d54b709.tar.xz
main/ebtables: fix extension initialization (on arm especially)
fixes #5388
Diffstat (limited to 'main/ebtables/fix-extension-init.patch')
-rw-r--r--main/ebtables/fix-extension-init.patch249
1 files changed, 249 insertions, 0 deletions
diff --git a/main/ebtables/fix-extension-init.patch b/main/ebtables/fix-extension-init.patch
new file mode 100644
index 0000000000..4812b4de2d
--- /dev/null
+++ b/main/ebtables/fix-extension-init.patch
@@ -0,0 +1,249 @@
+--- ebtables-v2.0.10-4.orig/extensions/Makefile
++++ ebtables-v2.0.10-4/extensions/Makefile
+@@ -11,13 +11,13 @@
+ EXT_LIBSI+=$(foreach T,$(EXT_TABLES), -lebtable_$(T))
+
+ extensions/ebt_%.so: extensions/ebt_%.o
+- $(CC) $(LDFLAGS) -shared -o $@ -lc $< -nostartfiles
++ $(CC) $(LDFLAGS) -shared -o $@ -lc $<
+
+ extensions/libebt_%.so: extensions/ebt_%.so
+ mv $< $@
+
+ extensions/ebtable_%.so: extensions/ebtable_%.o
+- $(CC) $(LDFLAGS) -shared -o $@ -lc $< -nostartfiles
++ $(CC) $(LDFLAGS) -shared -o $@ -lc $<
+
+ extensions/libebtable_%.so: extensions/ebtable_%.so
+ mv $< $@
+--- ebtables-v2.0.10-4.orig/extensions/ebt_802_3.c
++++ ebtables-v2.0.10-4/extensions/ebt_802_3.c
+@@ -141,7 +141,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&_802_3_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_among.c
++++ ebtables-v2.0.10-4/extensions/ebt_among.c
+@@ -491,7 +491,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&among_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_arp.c
++++ ebtables-v2.0.10-4/extensions/ebt_arp.c
+@@ -362,7 +362,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&arp_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_arpreply.c
++++ ebtables-v2.0.10-4/extensions/ebt_arpreply.c
+@@ -133,7 +133,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_target(&arpreply_target);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_ip.c
++++ ebtables-v2.0.10-4/extensions/ebt_ip.c
+@@ -338,7 +338,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&ip_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_ip6.c
++++ ebtables-v2.0.10-4/extensions/ebt_ip6.c
+@@ -556,7 +556,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&ip6_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_limit.c
++++ ebtables-v2.0.10-4/extensions/ebt_limit.c
+@@ -212,7 +212,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&limit_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_log.c
++++ ebtables-v2.0.10-4/extensions/ebt_log.c
+@@ -217,7 +217,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_watcher(&log_watcher);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_mark.c
++++ ebtables-v2.0.10-4/extensions/ebt_mark.c
+@@ -172,7 +172,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_target(&mark_target);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_mark_m.c
++++ ebtables-v2.0.10-4/extensions/ebt_mark_m.c
+@@ -121,7 +121,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&mark_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_nat.c
++++ ebtables-v2.0.10-4/extensions/ebt_nat.c
+@@ -231,7 +231,7 @@
+ .extra_ops = opts_d,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_target(&snat_target);
+ ebt_register_target(&dnat_target);
+--- ebtables-v2.0.10-4.orig/extensions/ebt_nflog.c
++++ ebtables-v2.0.10-4/extensions/ebt_nflog.c
+@@ -166,7 +166,7 @@
+ .extra_ops = nflog_opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_watcher(&nflog_watcher);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_pkttype.c
++++ ebtables-v2.0.10-4/extensions/ebt_pkttype.c
+@@ -125,7 +125,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&pkttype_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_redirect.c
++++ ebtables-v2.0.10-4/extensions/ebt_redirect.c
+@@ -108,7 +108,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_target(&redirect_target);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_standard.c
++++ ebtables-v2.0.10-4/extensions/ebt_standard.c
+@@ -84,7 +84,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_target(&standard);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_stp.c
++++ ebtables-v2.0.10-4/extensions/ebt_stp.c
+@@ -337,7 +337,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&stp_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_ulog.c
++++ ebtables-v2.0.10-4/extensions/ebt_ulog.c
+@@ -180,7 +180,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_watcher(&ulog_watcher);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_vlan.c
++++ ebtables-v2.0.10-4/extensions/ebt_vlan.c
+@@ -181,7 +181,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&vlan_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebtable_broute.c
++++ ebtables-v2.0.10-4/extensions/ebtable_broute.c
+@@ -23,7 +23,7 @@
+ .help = print_help,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_table(&table);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebtable_filter.c
++++ ebtables-v2.0.10-4/extensions/ebtable_filter.c
+@@ -29,7 +29,7 @@
+ .help = print_help,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_table(&table);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebtable_nat.c
++++ ebtables-v2.0.10-4/extensions/ebtable_nat.c
+@@ -30,7 +30,7 @@
+ .help = print_help,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_table(&table);
+ }