aboutsummaryrefslogtreecommitdiffstats
path: root/main/lftp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-17 12:55:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-17 12:56:13 +0000
commit3614033cdce115a35ab232057fbfea747b2d8219 (patch)
tree4e9ac9bd84741e226c34868fb577ff3326475314 /main/lftp
parent0f9935dbde2ee3ecea57f79095c4d17afb39a77c (diff)
downloadaports-3614033cdce115a35ab232057fbfea747b2d8219.tar.bz2
aports-3614033cdce115a35ab232057fbfea747b2d8219.tar.xz
main/lftp: fix building on uclibc
Diffstat (limited to 'main/lftp')
-rw-r--r--main/lftp/APKBUILD15
-rw-r--r--main/lftp/stdc-limit-macros.patch41
2 files changed, 51 insertions, 5 deletions
diff --git a/main/lftp/APKBUILD b/main/lftp/APKBUILD
index c4d095f463..a3d4cd55ed 100644
--- a/main/lftp/APKBUILD
+++ b/main/lftp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=lftp
pkgver=4.4.15
-pkgrel=2
+pkgrel=3
pkgdesc="LFTP is sophisticated ftp/http client"
url="http://lftp.yar.ru/"
arch="all"
@@ -12,7 +12,9 @@ makedepends="gnutls-dev readline-dev ncurses-dev gettext-dev autoconf automake
libtool"
subpackages="$pkgname-doc"
source="http://lftp.yar.ru/ftp/lftp-$pkgver.tar.xz
- 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
+ 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch
+ stdc-limit-macros.patch
+ "
_builddir="$srcdir/$pkgname-$pkgver"
@@ -56,8 +58,11 @@ package() {
}
md5sums="f19cc0cea1d427aa2a952b27661b91e5 lftp-4.4.15.tar.xz
-91de52bcbda9490d62cea72be78ab72a 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
+91de52bcbda9490d62cea72be78ab72a 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch
+c2e3e6b4aabd97658fe8488ff6859ea0 stdc-limit-macros.patch"
sha256sums="75f40b7ab438a7b295410eb3e1ec8460e36ad2d48785383a6fc9201905db6868 lftp-4.4.15.tar.xz
-e50ae5f0db272a31146cc29909bd07a1b7c11c78dad6e9a51eb3ad4231b5c323 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
+e50ae5f0db272a31146cc29909bd07a1b7c11c78dad6e9a51eb3ad4231b5c323 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch
+9dcb0f0ef32e3a27c955aadf6af4d60ce98d14df8bc9bc0fcf72f7c6479d555b stdc-limit-macros.patch"
sha512sums="1d828a7b2ff808a0ee78f51c265d58df677e67cec9b4744cbd3a34816aba324199202094fa4144665e8d64385df7e76a54c6dc415e9ff33e97adab2eb0edaf4e lftp-4.4.15.tar.xz
-3f7e7958787c323b148415ba42d8748d27a515da2dbc62c087e778190806cf6f683900966c359829d3ba1a4d8d06a874d35c41316c89059b1c85806328f422cc 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
+3f7e7958787c323b148415ba42d8748d27a515da2dbc62c087e778190806cf6f683900966c359829d3ba1a4d8d06a874d35c41316c89059b1c85806328f422cc 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch
+ba7ae5f68382a8bb24ed4a2313a224cf5ac5e105bc15ab22c3f43578cb4cb6cc436d8f7327e5da2b9f3c28ab5532123f7db6ea12d9ba3cba12b8f9cf71bb3632 stdc-limit-macros.patch"
diff --git a/main/lftp/stdc-limit-macros.patch b/main/lftp/stdc-limit-macros.patch
new file mode 100644
index 0000000000..3124fdede8
--- /dev/null
+++ b/main/lftp/stdc-limit-macros.patch
@@ -0,0 +1,41 @@
+diff --git a/configure.ac b/configure.ac
+index 5d52f1a..2f4142d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -127,6 +127,7 @@ CXX_DYNAMIC_INITIALIZERS
+ LFTP_CXX_BOOL
+ LFTP_CXX__BOOL
+ LFTP_CXX_ANSI_SCOPE
++LFTP_CXX_STDC_LIMIT_MACROS
+
+ AC_ISC_POSIX
+
+diff --git a/m4/lftp.m4 b/m4/lftp.m4
+index 1aae69e..72d594a 100644
+--- a/m4/lftp.m4
++++ b/m4/lftp.m4
+@@ -311,3 +311,23 @@ AC_DEFUN([LFTP_POSIX_FADVISE_CHECK],[
+ AC_DEFINE(HAVE_POSIX_FADVISE, 1, [Define if posix_fadvise() is available])
+ fi
+ ])
++
++AC_DEFUN([LFTP_CXX_STDC_LIMIT_MACROS],[
++ dnl * Old glibcs requires that __STDC_LIMIT_MACROS is defined for using
++ dnl * stdint.h in c++ mode
++ AC_MSG_CHECKING(whether stdint.h needs __STDC_LIMIT_MACROS in C++ mode)
++ AC_CACHE_VAL(lftp_cv_cxx_stdc_limit_macros,
++ [
++ AC_LANG_PUSH(C++)
++ AC_TRY_COMPILE([
++ #include <stdint.h>
++ int i = INT_MIN==INT32_MIN && INT_MAX == INT32_MAX;],[],
++ [lftp_cv_cxx_stdc_limit_macros=no],[lftp_cv_cxx_stdc_limit_macros=yes])
++ AC_LANG_POP(C++)
++ ])
++ AC_MSG_RESULT($lftp_cv_cxx_stdc_limit_macros)
++ if test x$lftp_cv_cxx_stdc_limit_macros = xyes; then
++ AC_DEFINE(__STDC_LIMIT_MACROS, 1, [Use STDC Limit Macros in C++])
++ fi
++])
++
+