aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxcb
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-05-29 19:04:04 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-06-01 14:55:42 +0000
commit91418f201986e427bfd56142a16e43fcd1e09fb9 (patch)
tree8c6dad3b3a688e15052ead76b57a4fd09967a011 /main/libxcb
parentb135ff5ed4a8ca3b6fc03ea1222c1bc4582dac65 (diff)
downloadaports-91418f201986e427bfd56142a16e43fcd1e09fb9.tar.bz2
aports-91418f201986e427bfd56142a16e43fcd1e09fb9.tar.xz
main/libxcb: clarify license, improve abuild
Diffstat (limited to 'main/libxcb')
-rw-r--r--main/libxcb/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/main/libxcb/APKBUILD b/main/libxcb/APKBUILD
index 31009de0c1..53b5672933 100644
--- a/main/libxcb/APKBUILD
+++ b/main/libxcb/APKBUILD
@@ -1,16 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxcb
pkgver=1.13
-pkgrel=0
+pkgrel=1
pkgdesc="X11 client-side library"
-url="https://xcb.freedesktop.org/"
+url="https://xcb.freedesktop.org"
arch="all"
-license="custom"
+license="MIT"
depends=
subpackages="$pkgname-dev $pkgname-doc"
depends_dev="libxau-dev xcb-proto"
checkdepends="check-dev"
-makedepends="$depends_dev libxslt python3 libpthread-stubs libxdmcp-dev"
+makedepends="$depends_dev libpthread-stubs libxdmcp-dev libxslt python3"
source="https://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir"/$pkgname-$pkgver
@@ -23,14 +23,13 @@ build() {
--prefix=/usr \
--enable-xkb \
--enable-xinput \
- --disable-xprint \
+ --disable-xprint
make
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
check() {