aboutsummaryrefslogtreecommitdiffstats
path: root/main/python3
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-08-29 13:43:48 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 13:43:48 +0000
commitb45cccb2ae58750d9b4958b687ffe11e6d7c8955 (patch)
tree312d6cc50a6dc83f3f2b2c1f8fb367ac3354a69f /main/python3
parentfe86583c31ebbdf9889e36992ecedc60cb928964 (diff)
downloadaports-b45cccb2ae58750d9b4958b687ffe11e6d7c8955.tar.bz2
aports-b45cccb2ae58750d9b4958b687ffe11e6d7c8955.tar.xz
main/python3: force parallelize tests, disable more checks
additional test failures on armhf
Diffstat (limited to 'main/python3')
-rw-r--r--main/python3/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/main/python3/APKBUILD b/main/python3/APKBUILD
index 264a69196d..d92dc4004d 100644
--- a/main/python3/APKBUILD
+++ b/main/python3/APKBUILD
@@ -57,9 +57,9 @@ check() {
# slow running
slow="test_faulthandler test_tokenize test_tools"
# failures
- fail="test__locale test_capi test_fcntl test_locale test_os test_posix"
- fail="$fail test_re test_shutil test_strptime test_threadsignals test_time"
- make quicktest EXTRATESTOPTS="--exclude $slow $fail"
+ fail="test__locale test_capi test_datetime test_fcntl test_hash test_locale test_os test_plistlib"
+ fail="$fail test_posix test_re test_shutil test_strptime test_threadsignals test_time"
+ make quicktest TESTOPTS="-j ${JOBS:-$(getconf _NPROCESSORS_ONLN)} --exclude $slow $fail"
}
package() {