aboutsummaryrefslogtreecommitdiffstats
path: root/testing/crystal/paxmark.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-26 01:47:50 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-03-26 02:36:13 +0200
commit75525e155b4527463993b539b3f56593975e6ed5 (patch)
tree22b31cc470198fd4eaac6a2cbecb9e78f53021ee /testing/crystal/paxmark.patch
parent553e9ff15be8508499cbab579fbb1c5933da054c (diff)
downloadaports-75525e155b4527463993b539b3f56593975e6ed5.tar.bz2
aports-75525e155b4527463993b539b3f56593975e6ed5.tar.xz
testing/crystal: tests need MPROTECT to be disabled
Diffstat (limited to 'testing/crystal/paxmark.patch')
-rw-r--r--testing/crystal/paxmark.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/crystal/paxmark.patch b/testing/crystal/paxmark.patch
new file mode 100644
index 0000000000..db6efd89db
--- /dev/null
+++ b/testing/crystal/paxmark.patch
@@ -0,0 +1,22 @@
+Make tests run on Grsecurity system. This patch is downstream only.
+
+--- a/Makefile
++++ b/Makefile
+@@ -104,14 +104,17 @@
+ $(O)/all_spec: $(DEPS) $(SOURCES) $(SPEC_SOURCES)
+ @mkdir -p $(O)
+ $(BUILD_PATH) ./bin/crystal build $(FLAGS) -o $@ spec/all_spec.cr
++ paxmark m $(O)/all_spec
+
+ $(O)/std_spec: $(DEPS) $(SOURCES) $(SPEC_SOURCES)
+ @mkdir -p $(O)
+ $(BUILD_PATH) ./bin/crystal build $(FLAGS) -o $@ spec/std_spec.cr
++ paxmark m $(O)/std_spec
+
+ $(O)/compiler_spec: $(DEPS) $(SOURCES) $(SPEC_SOURCES)
+ @mkdir -p $(O)
+ $(BUILD_PATH) ./bin/crystal build $(FLAGS) -o $@ spec/compiler_spec.cr
++ paxmark m $(O)/compiler_spec
+
+ $(O)/crystal: $(DEPS) $(SOURCES)
+ @mkdir -p $(O)